中危 Rust lru crate 资源管理错误漏洞(CVE-2021-45720)

CVE编号

CVE-2021-45720

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-12-27
漏洞描述
Rust lru crate是LRU 缓存的实现。

Rust lru crate 0.7.1 之前版本存在安全漏洞,该漏洞可导致资源管理错误。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://rustsec.org/advisories/RUSTSEC-2021-0130.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 lru_cache_project lru_cache * Up to
(excluding)
0.7.1
运行在以下环境
系统 fedora_35 389-ds-base-debuginfo * Up to
(excluding)
2.0.13-1.fc35
阿里云评分
4.8
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-416 释放后使用
阿里云安全产品覆盖情况