中危 Vim 缓冲区错误漏洞

CVE编号

CVE-2022-0128

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-01-07
漏洞描述
Vim是一款基于UNIX平台的编辑器。

vim存在缓冲区错误漏洞,攻击者利用该漏洞可以非法读取内存数据。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/vim/vim/commit/d3a117814d6acbf0dca3eff1a7626843b9b3734a
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 vim vim * Up to
(excluding)
8.2.4009
运行在以下环境
系统 alpine_3.12 vim * Up to
(excluding)
8.2.4173-r0
运行在以下环境
系统 alpine_3.13 vim * Up to
(excluding)
8.2.4173-r0
运行在以下环境
系统 alpine_3.14 vim * Up to
(excluding)
8.2.4173-r0
运行在以下环境
系统 alpine_3.15 vim * Up to
(excluding)
8.2.4173-r0
运行在以下环境
系统 alpine_3.16 vim * Up to
(excluding)
8.2.4173-r0
运行在以下环境
系统 alpine_edge vim * Up to
(excluding)
8.2.4173-r0
运行在以下环境
系统 debian_12 vim * Up to
(excluding)
8.2.3995-1
运行在以下环境
系统 debian_sid vim * Up to
(excluding)
8.2.3995-1
运行在以下环境
系统 fedora_34 vim * Up to
(excluding)
8.2.4232-1.fc34
运行在以下环境
系统 fedora_35 vim * Up to
(excluding)
8.2.4198-1.fc35
阿里云评分
5.5
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况