中危 Linux kernel 输入验证错误漏洞

CVE编号

CVE-2022-0185

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-01-20
漏洞描述

Linux kernel是美国Linux基金会的开源操作系统Linux所使用的内核。

Linux kernel 存在输入验证错误漏洞,该漏洞源于在 Linux kernel 的 Filesystem Context 中的 legacy_parse_param 函数验证提供的参数长度的方式中发现了一个基于堆的缓冲区溢出缺陷。 非特权(在启用非特权用户命名空间的情况下,否则需要命名空间的 CAP_SYS_ADMIN 特权)本地用户能够打开不支持文件系统上下文 API 的文件系统(因此回退到遗留处理)可以使用此缺陷来提升他们在系统上的权限。
解决建议

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://access.redhat.com/security/cve/cve-2022-0185
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 amazon_2 linux * Up to
(excluding)
5.4.172-90.336.amzn2
运行在以下环境
系统 centos_8 kpatch-patch * Up to
(excluding)
4_18_0-348_7_1-1-1.el8_5
运行在以下环境
系统 debian_11 linux * Up to
(excluding)
5.10.92-1
运行在以下环境
系统 fedora_34 kernel * Up to
(excluding)
5.15.16-100.fc34
运行在以下环境
系统 fedora_35 kernel * Up to
(excluding)
5.15.16-200.fc35
运行在以下环境
系统 linux linux_kernel * From
(including)
5.1
Up to
(including)
5.16
运行在以下环境
系统 opensuse_Leap_15.3 linux * Up to
(excluding)
5.3.18-150300.38.37.1
运行在以下环境
系统 opensuse_Leap_15.4 linux * Up to
(excluding)
5.3.18-150300.59.43.1
运行在以下环境
系统 oracle_7 kernel * Up to
(excluding)
5.4.17-2136.302.7.2.1.el8
运行在以下环境
系统 oracle_8 kernel * Up to
(excluding)
4.18.0-348.12.2.el8_5
运行在以下环境
系统 redhat_8 kpatch-patch * Up to
(excluding)
4_18_0-348_7_1-1-1.el8_5
运行在以下环境
系统 ubuntu_14.04 linux * Up to
(excluding)
4.15.0-1023.24~14.04.1
运行在以下环境
系统 ubuntu_18.04 linux * Up to
(excluding)
4.4.0-1077.82
运行在以下环境
系统 ubuntu_20.04 linux * Up to
(excluding)
5.4.0-1061.65
运行在以下环境
系统 ubuntu_21.04 linux * Up to
(excluding)
5.11.0-1027.30
运行在以下环境
系统 ubuntu_21.10 linux * Up to
(excluding)
5.13.0-1010.11
阿里云评分
4.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-190 整数溢出或超界折返
阿里云安全产品覆盖情况