中危 Vim 缓冲区错误漏洞

CVE编号

CVE-2022-0318

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-01-21
漏洞描述
Vim是一款基于UNIX平台的编辑器。

vim 存在缓冲区错误漏洞,该漏洞源于 vim 中基于堆的缓冲区溢出。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/vim/vim/commit/57df9e8a9f9ae1aafdde9b86b10ad907627a87dc
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 vim vim * Up to
(excluding)
8.2.4151
运行在以下环境
系统 amazon_2 vim * Up to
(excluding)
8.2.4314-1.amzn2.0.1
运行在以下环境
系统 amazon_AMI vim * Up to
(excluding)
8.2.4314-1.1.amzn1
运行在以下环境
系统 debian_10 vim * Up to
(including)
8.1.0875-5+deb10u2
运行在以下环境
系统 debian_11 vim * Up to
(including)
8.2.2434-3+deb11u1
运行在以下环境
系统 debian_12 vim * Up to
(including)
8.2.3995-1
运行在以下环境
系统 debian_9 vim * Up to
(including)
8.0.0197-4+deb9u3
运行在以下环境
系统 debian_sid vim * Up to
(including)
8.2.3995-1
运行在以下环境
系统 fedora_34 vim * Up to
(excluding)
8.2.4232-1.fc34
运行在以下环境
系统 fedora_35 vim * Up to
(excluding)
8.2.4198-1.fc35
运行在以下环境
系统 opensuse_Leap_15.3 vim * Up to
(excluding)
8.0.1568-5.17.1
运行在以下环境
系统 opensuse_Leap_15.4 vim * Up to
(excluding)
8.0.1568-5.17.1
运行在以下环境
系统 oracle_8 vim * Up to
(excluding)
8.0.1763-16.0.1.el8_5.12
运行在以下环境
系统 redhat_8 vim * Up to
(excluding)
8.0.1763-16.el8_5.12
运行在以下环境
系统 ubuntu_16.04 vim * Up to
(excluding)
2:7.4.1689-3ubuntu1.5+esm4
阿里云评分
5.6
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-122 堆缓冲区溢出
阿里云安全产品覆盖情况