高危 Linux kernel 缓冲区错误漏洞(CVE-2022-0995)

CVE编号

CVE-2022-0995

利用情况

EXP 已公开

补丁情况

官方补丁

披露时间

2022-03-26
该漏洞EXP已公开传播,漏洞利用成本极低,建议您立即关注并修复。
漏洞描述
Linux kernel是美国Linux基金会的开源操作系统Linux所使用的内核。

Linux kernel 存在安全漏洞,攻击者可以通过 watch_queue 触发 Linux 内核的内存损坏,以触发拒绝服务,并可能运行代码。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=93ce93587d36493f2f86921fa79921b3cba63fbb
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 debian_10 linux * Up to
(including)
4.19.208-1
运行在以下环境
系统 debian_11 linux * Up to
(excluding)
5.10.106-1
运行在以下环境
系统 debian_12 linux * Up to
(including)
5.16.14-1
运行在以下环境
系统 debian_9 linux * Up to
(including)
4.9.228-1
运行在以下环境
系统 debian_sid linux * Up to
(including)
5.16.14-1
运行在以下环境
系统 fedoraproject fedora 35 -
运行在以下环境
系统 fedora_34 kernel * Up to
(excluding)
5.16.15-101.fc34
运行在以下环境
系统 fedora_34 linux * Up to
(excluding)
5.16.15-101.fc34
运行在以下环境
系统 fedora_35 kernel * Up to
(excluding)
5.16.15-201.fc35
运行在以下环境
系统 fedora_35 linux * Up to
(excluding)
5.16.15-201.fc35
运行在以下环境
系统 linux linux_kernel * Up to
(including)
5.16
运行在以下环境
系统 linux linux_kernel 5.17 -
运行在以下环境
系统 ubuntu_18.04 linux * Up to
(excluding)
4.4.0-1077.82
阿里云评分
7.1
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    EXP 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况