高危 Gitlab OmniAuth 账号劫持漏洞(CVE-2022-1162)

CVE编号

CVE-2022-1162

利用情况

POC 已公开

补丁情况

官方补丁

披露时间

2022-04-05
漏洞描述
GitLab 是一个用于代码仓库管理系统的开源项目,使用Git作为代码管理工具,并在此基础上搭建起来的Web服务。

据官方描述,系统会默认给使用了 OmniAuth 程序(例如 OAuth、LDAP、SAML)注册的帐户设置一个硬编码密码,从而允许攻击者可直接通过该硬编码密码登录并接管帐户。

受影响版本:
Gitlab CE/EE >=14.7, <14.7.7
Gitlab CE/EE >=14.8, <14.8.5
Gitlab CE/EE >=14.9, <14.9.2

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

http://about.gitlab.com/releases/2022/03/31/critical-security-release-gitlab-14-9-2-released/

建议使用安全版本:
Gitlab CE/EE >=14.7.7
Gitlab CE/EE >=14.8.5
Gitlab CE/EE >=14.9.2



受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gitlab gitlab * From
(including)
14.7.0
Up to
(excluding)
14.7.7
运行在以下环境
应用 gitlab gitlab * From
(including)
14.8.0
Up to
(excluding)
14.8.5
运行在以下环境
应用 gitlab gitlab * From
(including)
14.9.0
Up to
(excluding)
14.9.2
运行在以下环境
系统 debian_sid gitlab * Up to
(including)
13.4.7-2
阿里云评分
8.0
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    POC 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-260 配置文件中存储口令
CWE-798 使用硬编码的凭证
阿里云安全产品覆盖情况