中危 Mutt 缓冲区错误漏洞(CVE-2022-1328)

CVE编号

CVE-2022-1328

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-04-15
漏洞描述
Mutt是Michael Elkins个人开发者的一款用于类Unix系统下且基于文本的邮件客户端。

Mutt 0.94.13到2.2.3版本存在安全漏洞,该漏洞源于应用允许读取输入行的末尾从而导致缓冲区溢出问题。
解决建议

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://gitlab.com/muttmua/mutt/-/commit/e5ed080c00e59701ca62ef9b2a6d2612ebf765a5
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 mutt mutt * From
(including)
0.94.13
Up to
(excluding)
2.2.3
运行在以下环境
系统 alpine_3.15 mutt * Up to
(excluding)
2.2.3-r0
运行在以下环境
系统 alpine_3.16 mutt * Up to
(excluding)
2.2.3-r0
运行在以下环境
系统 alpine_edge mutt * Up to
(excluding)
2.2.3-r0
运行在以下环境
系统 debian_10 mutt * Up to
(including)
1.10.1-2.1+deb10u5
运行在以下环境
系统 debian_11 mutt * Up to
(including)
2.0.5-4.1
运行在以下环境
系统 debian_12 mutt * Up to
(including)
20211029+dfsg1-1
运行在以下环境
系统 debian_9 mutt * Up to
(excluding)
1.7.2-1+deb9u6
运行在以下环境
系统 debian_sid mutt * Up to
(including)
20211029+dfsg1-1
运行在以下环境
系统 fedora_36 mutt * Up to
(excluding)
2.2.3-1.fc36
运行在以下环境
系统 opensuse_Leap_15.4 mutt * Up to
(excluding)
20220429-bp154.2.3.1
运行在以下环境
系统 suse_12_SP5 mutt * Up to
(excluding)
1.10.1-55.27.1
运行在以下环境
系统 ubuntu_16.04 mutt * Up to
(excluding)
1.5.24-1ubuntu0.6+esm2
运行在以下环境
系统 ubuntu_18.04 mutt * Up to
(excluding)
1.9.4-3ubuntu0.6
运行在以下环境
系统 ubuntu_20.04 mutt * Up to
(excluding)
1.13.2-1ubuntu0.5
运行在以下环境
系统 ubuntu_21.10 mutt * Up to
(excluding)
2.0.5-4.1ubuntu0.1
运行在以下环境
系统 ubuntu_22.04 mutt * Up to
(excluding)
2.1.4-1ubuntu1.1
阿里云评分
5.3
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-120 未进行输入大小检查的缓冲区拷贝(传统缓冲区溢出)
阿里云安全产品覆盖情况