中危 vim 缓冲区错误漏洞(CVE-2022-1420)

CVE编号

CVE-2022-1420

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-04-21
漏洞描述
vim是一款基于UNIX平台的编辑器。

vim存在安全漏洞,该漏洞源于在 8.2.4774 之前的 GitHub 存储库 vim/vim 中使用超出范围的指针偏移。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/vim/vim/commit/8b91e71441069b1dde9ac9ff9d9a829b1b4aecca
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 vim vim * Up to
(excluding)
8.2.4774
阿里云评分
4.6
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况