vim vim 跨界内存写

CVE编号

CVE-2022-1621

利用情况

暂无

补丁情况

N/A

披露时间

2022-05-10
漏洞描述
Heap buffer overflow in vim_strncpy find_word in GitHub repository vim/vim prior to 8.2.4919. This vulnerability is capable of crashing software, Bypass Protection Mechanism, Modify Memory, and possible remote execution
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 vim vim * Up to
(excluding)
8.2.4919
运行在以下环境
系统 alpine_3.16 vim * Up to
(excluding)
8.2.4969-r0
运行在以下环境
系统 alpine_edge vim * Up to
(excluding)
8.2.4969-r0
运行在以下环境
系统 debian_10 vim * Up to
(including)
8.1.0875-5+deb10u2
运行在以下环境
系统 debian_11 vim * Up to
(including)
8.2.2434-3+deb11u1
运行在以下环境
系统 debian_12 vim * Up to
(including)
8.2.4793-1
运行在以下环境
系统 debian_9 vim * Up to
(excluding)
2:8.0.0197-4+deb9u6
运行在以下环境
系统 debian_sid vim * Up to
(including)
8.2.4793-1
运行在以下环境
系统 fedora_34 vim * Up to
(excluding)
8.2.4927-1.fc34
运行在以下环境
系统 redhat_8 vim * Up to
(excluding)
8.0.1763-19.el8_6.2
运行在以下环境
系统 ubuntu_16.04 vim * Up to
(excluding)
2:7.4.1689-3ubuntu1.5+esm6
CVSS3评分
7.8
  • 攻击路径
    本地
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
    需要
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况