中危 Oracle MySQL 输入验证错误漏洞

CVE编号

CVE-2022-21245

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-02-07
漏洞描述
Oracle MySQL Server是美国甲骨文(Oracle)公司的一款关系型数据库。

MySQL Server存在输入验证错误漏洞,该漏洞的存在是由于 MySQL Server 中的 Server: Optimizer 组件中的输入验证不正确。远程认证用户可以利用此漏洞破坏或删除数据。该漏洞允许远程认证用户破坏或删除数据。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://www.cybersecurity-help.cz/vdb/SB2022011905
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 netapp oncommand_insight - -
运行在以下环境
应用 netapp oncommand_workflow_automation - -
运行在以下环境
应用 oracle mysql * From
(including)
5.7.0
Up to
(including)
5.7.36
运行在以下环境
应用 oracle mysql * From
(including)
8.0.0
Up to
(including)
8.0.27
运行在以下环境
系统 debian_sid mysql-8.0 * Up to
(including)
8.0.29-1
运行在以下环境
系统 fedora_34 mysql-8.0 * Up to
(excluding)
8.0.28-1.fc34
运行在以下环境
系统 fedora_35 mysql-8.0 * Up to
(excluding)
8.0.28-1.fc35
运行在以下环境
系统 ubuntu_16.04 mysql-5.7 * Up to
(excluding)
5.7.37-0ubuntu0.16.04.1+esm1
运行在以下环境
系统 ubuntu_18.04 mysql-5.7 * Up to
(excluding)
5.7.37-0ubuntu0.18.04.1
运行在以下环境
系统 ubuntu_20.04 mysql-5.7 * Up to
(excluding)
8.0.28-0ubuntu0.20.04.3
运行在以下环境
系统 ubuntu_21.10 mysql-5.7 * Up to
(excluding)
8.0.28-0ubuntu0.21.10.3
运行在以下环境
系统 ubuntu_22.04 mysql * Up to
(excluding)
8.0.28-0ubuntu2
阿里云评分
5.6
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况