vim vim 跨界内存写

CVE编号

CVE-2022-2129

利用情况

暂无

补丁情况

N/A

披露时间

2022-06-20
漏洞描述
Out-of-bounds Write in GitHub repository vim/vim prior to 8.2.
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 vim vim * Up to
(excluding)
8.2.5126
运行在以下环境
系统 alibaba_cloud_linux_2.1903 vim * Up to
(excluding)
11.0.14.0.9-1.1.al7
运行在以下环境
系统 alpine_edge vim * Up to
(excluding)
8.2.5170-r0
运行在以下环境
系统 amazon_2 vim * Up to
(excluding)
17.0.2+8-1.amzn2.1
运行在以下环境
系统 centos_7 vim * Up to
(excluding)
11.0.14.0.9-1.el7_9
运行在以下环境
系统 debian_10 vim * Up to
(including)
8.1.0875-5+deb10u2
运行在以下环境
系统 debian_11 vim * Up to
(including)
8.2.2434-3+deb11u1
运行在以下环境
系统 debian_12 vim * Up to
(including)
8.2.4793-1
运行在以下环境
系统 debian_9 vim * Up to
(including)
8.0.0197-4+deb9u3
运行在以下环境
系统 debian_sid vim * Up to
(including)
8.2.4793-1
运行在以下环境
系统 fedora_34 vim * Up to
(excluding)
11.0.14.1.1-4.fc34
运行在以下环境
系统 fedora_35 vim * Up to
(excluding)
8.2.5172-1.fc35
运行在以下环境
系统 fedora_36 vim * Up to
(excluding)
8.2.5172-1.fc36
运行在以下环境
系统 fedora_EPEL_8 vim * Up to
(excluding)
17.0.2.0.8-1.rolling.el8
运行在以下环境
系统 opensuse_Leap_15.3 vim * Up to
(excluding)
1.8.0_sr7.5-150000.3.56.1
运行在以下环境
系统 opensuse_Leap_15.4 vim * Up to
(excluding)
1.8.0_sr7.5-150000.3.56.1
运行在以下环境
系统 oracle_7 vim * Up to
(excluding)
11.0.14.0.9-1.0.1.el7_9
运行在以下环境
系统 oracle_8 vim * Up to
(excluding)
1.8.0.322.b06-2.el8_5
运行在以下环境
系统 redhat_7 java-11-openjdk * Up to
(excluding)
1:11.0.14.0.9-1.el7_9
运行在以下环境
系统 redhat_8 vim * Up to
(excluding)
1.8.0.7.5-1.el8_5
运行在以下环境
系统 suse_12_SP5 vim * Up to
(excluding)
1.8.0_sr7.5-30.87.1
CVSS3评分
7.8
  • 攻击路径
    本地
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
    需要
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况