中危 Oracle Java SE和GraalVM Enterprise Edition输入验证错误漏洞(CVE-2022-21349)

CVE编号

CVE-2022-21349

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-02-24
漏洞描述
Oracle GraalVM是美国甲骨文(Oracle)公司的一套使用Java语言编写的即时编译器。该产品支持多种编程语言和执行模式。GraalVM Enterprise Edition是GraalVM的企业版。
Oracle Java SE 7u321和8u311, Oracle GraalVM Enterprise Edition 20.3.4和21.3.0版本(组件: 2D)存在输入验证错误漏洞。未经身份认证的攻击者可利用该漏洞通过多种协议进行网络访问,从而破坏Oracle Java SE和Oracle GraalVM Enterprise Edition,并导致拒绝服务。

受影响系统:
Oracle Oracle Java SE 8u311
Oracle Oracle Java SE 7u321
Oracle Oracle GraalVM Enterprise Edition 21.3.0
Oracle Oracle GraalVM Enterprise Edition 20.3.4
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

http://www.oracle.com/security-alerts/cpujan2022.html?3082
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 netapp cloud_insights - -
运行在以下环境
应用 netapp e-series_santricity_os_controller * From
(including)
11.0.0
Up to
(including)
11.70.1
运行在以下环境
应用 netapp e-series_santricity_storage_manager - -
运行在以下环境
应用 netapp e-series_santricity_web_services - -
运行在以下环境
应用 netapp oncommand_insight - -
运行在以下环境
应用 netapp santricity_unified_manager - -
运行在以下环境
应用 netapp snapmanager - -
运行在以下环境
应用 oracle graalvm 20.3.4 -
运行在以下环境
应用 oracle graalvm 21.3.0 -
运行在以下环境
应用 oracle jdk 1.7.0 -
运行在以下环境
应用 oracle jdk 1.8.0 -
运行在以下环境
应用 oracle jdk 11.0.13 -
运行在以下环境
应用 oracle jdk 17.0.1 -
运行在以下环境
应用 oracle jre 1.7.0 -
运行在以下环境
应用 oracle jre 1.8.0 -
运行在以下环境
应用 oracle jre 11.0.13 -
运行在以下环境
应用 oracle jre 17.0.1 -
运行在以下环境
系统 alpine_3.15 openjdk8 * Up to
(excluding)
8.322.06-r0
运行在以下环境
系统 alpine_3.16 openjdk8 * Up to
(excluding)
8.322.06-r0
运行在以下环境
系统 alpine_edge openjdk8 * Up to
(excluding)
8.322.06-r0
运行在以下环境
系统 debian_9 openjdk-8 * Up to
(excluding)
8u322-b06-1~deb9u1
运行在以下环境
系统 debian_sid openjdk-8 * Up to
(including)
8u312-b07-1
运行在以下环境
系统 fedora_34 openjdk-8 * Up to
(excluding)
1.8.0.322.b06-2.fc34
运行在以下环境
系统 fedora_35 openjdk-8 * Up to
(excluding)
1.8.0.322.b06-2.fc35
运行在以下环境
系统 opensuse_Leap_15.3 openjdk-8 * Up to
(excluding)
1.8.0.322-3.64.2
运行在以下环境
系统 opensuse_Leap_15.4 openjdk-8 * Up to
(excluding)
1.8.0.322-3.64.2
运行在以下环境
系统 suse_12_SP5 openjdk-8 * Up to
(excluding)
1.8.0.322-27.72.2
阿里云评分
6.3
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况