中危 Oracle GraalVM 输入验证错误漏洞

CVE编号

CVE-2022-21360

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-01-29
漏洞描述
Oracle GraalVM是美国甲骨文(Oracle)公司的一套使用Java语言编写的即时编译器。该产品支持多种编程语言和执行模式。

Oracle GraalVM存在输入验证错误漏洞,该漏洞的存在是由于 Oracle GraalVM 企业版中序列化组件中的输入验证不正确。远程未经身份验证的攻击者可以利用此漏洞来操纵数据。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://www.oracle.com/security-alerts/cpujan2022.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 netapp cloud_insights - -
运行在以下环境
应用 netapp e-series_santricity_os_controller * From
(including)
11.0.0
Up to
(including)
11.70.1
运行在以下环境
应用 netapp e-series_santricity_storage_manager - -
运行在以下环境
应用 netapp e-series_santricity_web_services - -
运行在以下环境
应用 netapp oncommand_insight - -
运行在以下环境
应用 netapp santricity_unified_manager - -
运行在以下环境
应用 netapp snapmanager - -
运行在以下环境
应用 oracle graalvm 20.3.4 -
运行在以下环境
应用 oracle graalvm 21.3.0 -
运行在以下环境
应用 oracle jdk 1.7.0 -
运行在以下环境
应用 oracle jdk 1.8.0 -
运行在以下环境
应用 oracle jdk 11.0.13 -
运行在以下环境
应用 oracle jdk 17.0.1 -
运行在以下环境
应用 oracle jre 1.7.0 -
运行在以下环境
应用 oracle jre 1.8.0 -
运行在以下环境
应用 oracle jre 11.0.13 -
运行在以下环境
应用 oracle jre 17.0.1 -
运行在以下环境
系统 alibaba_cloud_linux_2.1903 java-11-openjdk-src * Up to
(excluding)
1.8.0.322.b06-1.1.al7
运行在以下环境
系统 alpine_3.14 openjdk11 * Up to
(excluding)
11.0.14_p9-r0
运行在以下环境
系统 alpine_3.15 openjdk11 * Up to
(excluding)
11.0.14_p9-r0
运行在以下环境
系统 alpine_3.16 openjdk11 * Up to
(excluding)
8.322.06-r0
运行在以下环境
系统 alpine_3.17 openjdk11 * Up to
(excluding)
8.322.06-r0
运行在以下环境
系统 alpine_3.18 openjdk11 * Up to
(excluding)
8.322.06-r0
运行在以下环境
系统 alpine_edge openjdk11 * Up to
(excluding)
11.0.14_p9-r0
运行在以下环境
系统 amazon_2 java-1.8.0-openjdk * Up to
(excluding)
11.0.14+9-1.amzn2
运行在以下环境
系统 amazon_2022 java-11-openjdk * Up to
(excluding)
17.0.2.0.8-2.rolling.amzn2022
运行在以下环境
系统 amazon_AMI java-1.8.0-openjdk * Up to
(excluding)
1.7.0-openjdk-1.7.0.321-2.6.28.1.86.amzn1
运行在以下环境
系统 anolis_os_7 java-11-openjdk-demo-debug * Up to
(excluding)
1.8.0.322
运行在以下环境
系统 anolis_os_8 java-17-openjdk-javadoc-zip * Up to
(excluding)
11.0.14.0.9-2
运行在以下环境
系统 centos_7 java * Up to
(excluding)
1.8.0.322.b06-1.el7_9
运行在以下环境
系统 centos_8 java-1.8.0-ibm-plugin * Up to
(excluding)
1.8.0.322.b06-2.el8_5
运行在以下环境
系统 debian_10 openjdk-11 * Up to
(excluding)
11.0.14+9-1~deb10u1
运行在以下环境
系统 debian_11 openjdk-11 * Up to
(excluding)
11.0.14+9-1~deb11u1
运行在以下环境
系统 debian_12 openjdk-17 * Up to
(excluding)
17.0.2+8-1
运行在以下环境
系统 debian_9 openjdk-8 * Up to
(excluding)
8u322-b06-1~deb9u1
运行在以下环境
系统 debian_sid openjdk-11 * Up to
(excluding)
11.0.14+9-1
运行在以下环境
系统 fedora_34 java-11-openjdk-demo-slowdebug * Up to
(excluding)
1.8.0.322.b06-2.fc34
运行在以下环境
系统 fedora_35 java-11-openjdk-headless-slowdebug * Up to
(excluding)
1.8.0.322.b06-2.fc35
运行在以下环境
系统 fedora_EPEL_8 java-latest-openjdk-debugsource * Up to
(excluding)
17.0.2.0.8-1.rolling.el8
运行在以下环境
系统 opensuse_Leap_15.3 java-1_8_0-ibm-plugin * Up to
(excluding)
11.0.14.0-3.74.2
运行在以下环境
系统 opensuse_Leap_15.4 java-1_8_0-ibm-src * Up to
(excluding)
1.8.0.322-3.64.2
运行在以下环境
系统 oracle_7 oraclelinux-release * Up to
(excluding)
1.8.0.322.b06-1.el7_9
运行在以下环境
系统 oracle_8 oraclelinux-release * Up to
(excluding)
11.0.14.0.9-2.el8_5
运行在以下环境
系统 redhat_7 java-11-openjdk * Up to
(excluding)
1.8.0-ibm-1.8.0.7.5-1jpp.1.el7
运行在以下环境
系统 redhat_8 java-1.8.0-ibm-plugin * Up to
(excluding)
1.8.0.322.b06-2.el8_5
运行在以下环境
系统 suse_12_SP5 java-1_8_0-ibm-alsa * Up to
(excluding)
1.7.1_sr5.5-38.68.1
运行在以下环境
系统 ubuntu_18.04 openjdk-17 * Up to
(excluding)
8u342-b07-0ubuntu1~18.04
运行在以下环境
系统 ubuntu_20.04 openjdk-17 * Up to
(excluding)
8u342-b07-0ubuntu1~20.04
运行在以下环境
系统 ubuntu_21.10 openjdk-17 * Up to
(excluding)
17.0.2+8-1~22.10
运行在以下环境
系统 ubuntu_22.04 openjdk-8 * Up to
(excluding)
8u342-b07-0ubuntu1~22.04
运行在以下环境
系统 unionos_d openjdk-11 * Up to
(excluding)
11.0.16.1+8-1+dde
阿里云评分
5.2
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况