高危 Gitlab Project import 远程代码执行漏洞(CVE-2022-2185)

CVE编号

CVE-2022-2185

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-07-01
漏洞描述
GitLab是一个用于仓库管理系统的开源项目。漏洞利用需要经过登录认证,经过认证的攻击者可以利用project导入功能执行任意代码,控制服务器。

影响版本:
GitLab CE/EE 14.0.x < 14.10.5
GitLab CE/EE 15.0.x < 15.0.4
GitLab CE/EE 15.1.x < 15.1.1


安全版本:
GitLab CE/EE 14.10.5
GitLab CE/EE 15.0.4
GitLab CE/EE 15.1.1
解决建议
1、强烈建议升级至安全版本。
2、关闭Gitlab对外注册功能,防止外界攻击者注册登录。
3、利用阿里云安全组功能设置Gitlab仅对可信地址开放
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gitlab gitlab * From
(including)
14.0.0
Up to
(excluding)
14.10.5
运行在以下环境
应用 gitlab gitlab * From
(including)
15.0.0
Up to
(excluding)
15.0.4
运行在以下环境
应用 gitlab gitlab 15.1.0 -
阿里云评分
7.5
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    普通权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-732 关键资源的不正确权限授予
阿里云安全产品覆盖情况