中危 Apple macOS 代码注入漏洞

CVE编号

CVE-2022-22589

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-01-29
漏洞描述
Apple macOS是美国苹果(Apple)公司的一套专为Mac计算机所开发的专用操作系统。

Apple macOS Monterey 12.2存在代码注入漏洞,该漏洞源于处理电子邮件时WebKit中的输入验证不正确。攻击者可利用该漏洞诱骗受害者打开特别制作的电子邮件消息,并在系统上执行任意JavaScript代码。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://support.apple.com/en-us/HT213054
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apple safari * Up to
(excluding)
15.3
运行在以下环境
系统 alpine_3.16 webkit2gtk * Up to
(excluding)
2.34.6-r0
运行在以下环境
系统 alpine_edge webkit2gtk * Up to
(excluding)
2.34.6-r0
运行在以下环境
系统 apple ipados * Up to
(excluding)
15.3
运行在以下环境
系统 apple iphone_os * Up to
(excluding)
15.3
运行在以下环境
系统 apple macos * From
(including)
12.0.0
Up to
(excluding)
12.2
运行在以下环境
系统 apple tvos * Up to
(excluding)
15.3
运行在以下环境
系统 apple watchos * Up to
(excluding)
8.4
运行在以下环境
系统 centos_8 webkit2gtk * Up to
(excluding)
2.34.6-1.el8
运行在以下环境
系统 debian_10 webkit2gtk * Up to
(excluding)
2.34.6-1~deb10u1
运行在以下环境
系统 debian_11 webkit2gtk * Up to
(excluding)
2.34.6-1~deb11u1
运行在以下环境
系统 debian_12 webkit2gtk * Up to
(including)
2.34.4-1
运行在以下环境
系统 debian_9 webkit2gtk * Up to
(including)
2.18.6-1~deb9u1
运行在以下环境
系统 fedora_34 webkit2gtk3-debuginfo * Up to
(excluding)
2.34.5-1.fc34
运行在以下环境
系统 fedora_35 webkit2gtk3-debugsource * Up to
(excluding)
2.34.5-1.fc35
运行在以下环境
系统 opensuse_Leap_15.3 webkit2gtk * Up to
(excluding)
2.34.6-29.1
运行在以下环境
系统 opensuse_Leap_15.4 webkit2gtk * Up to
(excluding)
2.34.6-29.1
运行在以下环境
系统 redhat_8 webkit2gtk * Up to
(excluding)
2.34.6-1.el8
运行在以下环境
系统 suse_12_SP5 webkit2gtk * Up to
(excluding)
2.34.5-2.85.3
运行在以下环境
系统 ubuntu_20.04 webkit2gtk * Up to
(excluding)
2.34.6-0ubuntu0.20.04.1
运行在以下环境
系统 ubuntu_21.10 webkit2gtk * Up to
(excluding)
2.34.6-0ubuntu0.21.10.1
运行在以下环境
系统 ubuntu_22.04 webkit2gtk * Up to
(excluding)
2.35.3-1ubuntu1
阿里云评分
5.8
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况