中危 Django 跨站脚本漏洞

CVE编号

CVE-2022-22818

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-02-03
漏洞描述
Django是Django基金会的一套基于Python语言的开源Web应用框架。该框架包括面向对象的映射器、视图系统、模板系统等。
Django 中存在跨站脚本漏洞,该漏洞源于产品的debug模版标签不能正确的编码上下文数据。攻击者可通过该漏洞执行客户端代码。

受影响版本:
Django 2.2.27 之前版本
Django 3.2.12 之前版本
Django 4.0.2 之前版本
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://docs.djangoproject.com
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 djangoproject django * From
(including)
2.2
Up to
(excluding)
2.2.27
运行在以下环境
应用 djangoproject django * From
(including)
3.2
Up to
(excluding)
3.2.12
运行在以下环境
应用 djangoproject django * From
(including)
4.0
Up to
(excluding)
4.0.2
运行在以下环境
系统 alpine_3.16 py3-django * Up to
(excluding)
3.2.12-r0
运行在以下环境
系统 alpine_3.17 py3-django * Up to
(excluding)
3.2.12-r0
运行在以下环境
系统 alpine_3.18 py3-django * Up to
(excluding)
3.2.12-r0
运行在以下环境
系统 alpine_3.19 py3-django * Up to
(excluding)
3.2.12-r0
运行在以下环境
系统 debian_10 python-django * Up to
(excluding)
1.11.29-1+deb10u4
运行在以下环境
系统 debian_11 python-django * Up to
(excluding)
2.2.28-1~deb11u1
运行在以下环境
系统 debian_12 python-django * Up to
(excluding)
3.2.12-1
运行在以下环境
系统 fedora_35 python-django * Up to
(excluding)
3.2.12-1.fc35
运行在以下环境
系统 fedora_36 python-django * Up to
(excluding)
4.0.2-1.fc36
运行在以下环境
系统 opensuse_Leap_15.3 python3-Django * Up to
(excluding)
2.2.28-bp153.2.3.1
运行在以下环境
系统 rocky_linux_8 libdb * Up to
(excluding)
5.3.28-42.el8_4
运行在以下环境
系统 ubuntu_18.04 python-django * Up to
(excluding)
1.11.11-1ubuntu1.16
运行在以下环境
系统 ubuntu_20.04 python-django * Up to
(excluding)
2.2.12-1ubuntu0.10
运行在以下环境
系统 ubuntu_21.10 python-django * Up to
(excluding)
2.2.24-1ubuntu1.3
运行在以下环境
系统 ubuntu_22.04 python-django * Up to
(excluding)
3.2.12-1
阿里云评分
6.2
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况