严重 Spring Cloud Gateway spel 远程代码执行(CVE-2022-22947)

CVE编号

CVE-2022-22947

利用情况

EXP 已公开

补丁情况

官方补丁

披露时间

2022-03-02
该漏洞EXP已公开传播,漏洞利用成本极低,建议您立即关注并修复。
漏洞描述
当 攻击者可以访问到 Spring Cloud Gateway actuator 端点时,攻击者可构造恶意请求,创建新路由,同时利用路由的filter功能注入spel表达式,从而造成表达式注入执行任意代码。
解决建议
1、针对 3.1.x 版本,建议升级至 3.1.1 及其以上版本。针对 3.0.x 版本,建议升级至 3.0.7 及其以上版本 。其余官方不再维护版本均建议升级至最新版本。
2、禁止外界访问 Spring Cloud Gateway actuator 端点 ,修改 spring 配置将 management.endpoint.gateway.enabled 置为 false,并重启服务使配置生效。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 vmware spring_cloud_gateway * Up to
(excluding)
3.0.7
运行在以下环境
应用 vmware spring_cloud_gateway 3.1.0 -
阿里云评分
9.9
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    EXP 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-627 动态变量执行
CWE-94 对生成代码的控制不恰当(代码注入)
阿里云安全产品覆盖情况