中危 Vmware Spring Framework 安全漏洞(CVE-2022-22950)

CVE编号

CVE-2022-22950

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-03-29
漏洞描述
Vmware Spring Framework是美国威睿(Vmware)公司的一套开源的Java、JavaEE应用程序框架。该框架可帮助开发人员构建高质量的应用。

Vmware Spring Framework 5.3.16 之前的 5.3 版本以及更老的不受支持的版本存在安全漏洞,该漏洞是由于 Spring Framework 对 SPEL 表达式处理不当,攻击者可利用该漏洞在未授权的情况下,构造恶意数据执行拒绝服务攻击,最终造成服务器拒绝服务。

受影响系统:
5.3.0< = Spring Framework < =5.3.16
5.2.0< = Spring Framework < =5.2.19

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://tanzu.vmware.com/security/cve-2022-22950
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 pivotal_software spring_framework * From
(including)
5.2.0
Up to
(excluding)
5.2.20
运行在以下环境
应用 pivotal_software spring_framework * From
(including)
5.3.0
Up to
(excluding)
5.3.17
运行在以下环境
系统 debian_10 libspring-java * Up to
(including)
4.3.22-4
运行在以下环境
系统 debian_11 libspring-java * Up to
(including)
4.3.30-1
运行在以下环境
系统 debian_12 libspring-java * Up to
(including)
4.3.30-1
运行在以下环境
系统 debian_9 libspring-java * Up to
(including)
4.3.5-1
运行在以下环境
系统 debian_sid libspring-java * Up to
(including)
4.3.30-1
阿里云评分
5.4
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-770 不加限制或调节的资源分配
阿里云安全产品覆盖情况