中危 Apache Tomcat 权限许可和访问控制问题漏洞

CVE编号

CVE-2022-23181

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-01-28
漏洞描述
Apache Tomcat是美国阿帕奇(Apache)基金会的一款轻量级Web应用服务器。该程序实现了对Servlet和JavaServer Page(JSP)的支持。

Apache Tomcat 存在权限许可和访问控制问题漏洞,攻击者可以通过 FileStore Sessions 绕过 Apache Tomcat 的限制,以提升他的权限。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://tomcat.apache.org/security-8.html#Fixed_in_Apache_Tomcat_8.5.75
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache tomcat * From
(including)
10.0.1
Up to
(including)
10.0.14
运行在以下环境
应用 apache tomcat * From
(including)
8.5.55
Up to
(including)
8.5.73
运行在以下环境
应用 apache tomcat * From
(including)
9.0.35
Up to
(including)
9.0.56
运行在以下环境
应用 apache tomcat 10.0.0 -
运行在以下环境
应用 apache tomcat 10.1.0 -
运行在以下环境
系统 amazon_AMI tomcat8 * Up to
(excluding)
8.5.75-1.90.amzn1
运行在以下环境
系统 debian_10 tomcat8 * Up to
(including)
9.0.31-1~deb10u6
运行在以下环境
系统 debian_11 tomcat8 * Up to
(including)
9.0.43-2~deb11u3
运行在以下环境
系统 debian_12 tomcat8 * Up to
(including)
9.0.58-1
运行在以下环境
系统 debian_9 tomcat8 * Up to
(including)
8.5.54-0+deb9u1
运行在以下环境
系统 debian_sid tomcat8 * Up to
(including)
9.0.58-1
运行在以下环境
系统 fedora_37 tomcat8 * Up to
(excluding)
9.0.59-1.fc37
运行在以下环境
系统 opensuse_Leap_15.3 tomcat8 * Up to
(excluding)
9.0.36-19.1
运行在以下环境
系统 opensuse_Leap_15.4 tomcat8 * Up to
(excluding)
9.0.36-19.1
运行在以下环境
系统 suse_12_SP5 tomcat8 * Up to
(excluding)
9.0.36-3.84.1
阿里云评分
5.8
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-367 检查时间与使用时间(TOCTOU)的竞争条件
阿里云安全产品覆盖情况