perforce puppet_bolt 信息暴露

CVE编号

CVE-2022-2394

利用情况

暂无

补丁情况

N/A

披露时间

2022-07-20
漏洞描述
Puppet Bolt prior to version 3.24.0 will print sensitive parameters when planning a run resulting in them potentially being logged when run programmatically, such as via Puppet Enterprise.
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 perforce puppet_bolt * Up to
(excluding)
3.24.0
运行在以下环境
系统 amazon_2 httpd * Up to
(excluding)
2.4.53-1.amzn2
运行在以下环境
系统 amazon_2022 httpd * Up to
(excluding)
2.4.54-3.amzn2022.0.3
运行在以下环境
系统 amazon_AMI httpd * Up to
(excluding)
2.4.53-1.96.amzn1
运行在以下环境
系统 fedora_34 httpd * Up to
(excluding)
6.3.0-2.fc34
运行在以下环境
系统 fedora_35 httpd * Up to
(excluding)
6.3.0-2.fc35
运行在以下环境
系统 fedora_36 httpd * Up to
(excluding)
2.4.53-1.fc36
运行在以下环境
系统 opensuse_Leap_15.3 httpd * Up to
(excluding)
2.4.51-150200.3.42.1
运行在以下环境
系统 suse_12_SP5 httpd * Up to
(excluding)
2.4.51-35.13.1
CVSS3评分
3.5
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
    需要
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-200 信息暴露
阿里云安全产品覆盖情况