中危 Apache HTTP Server 缓冲区错误漏洞

CVE编号

CVE-2022-23943

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-03-16
漏洞描述
Apache HTTP Server是美国阿帕奇(Apache)基金会的一款开源网页服务器。该服务器具有快速、可靠且可通过简单的API进行扩充的特点。

Apache HTTP Server 2.4 版本 2.4.52 和之前版本的 mod_sed 中存在缓冲区错误漏洞,该漏洞允许攻击者使用攻击者提供的数据覆盖堆内存。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://httpd.apache.org/security/vulnerabilities_24.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache http_server * From
(including)
2.4.0
Up to
(including)
2.4.52
运行在以下环境
系统 alpine_3.12 apache2 * Up to
(excluding)
2.4.53-r0
运行在以下环境
系统 alpine_3.13 apache2 * Up to
(excluding)
2.4.53-r0
运行在以下环境
系统 alpine_3.14 apache2 * Up to
(excluding)
2.4.53-r0
运行在以下环境
系统 alpine_3.15 apache2 * Up to
(excluding)
2.4.53-r0
运行在以下环境
系统 alpine_3.16 httpd * Up to
(excluding)
2.4.53-r0
运行在以下环境
系统 alpine_edge apache2 * Up to
(excluding)
2.4.53-r0
运行在以下环境
系统 amazon_2 httpd * Up to
(excluding)
2.4.53-1.amzn2
运行在以下环境
系统 amazon_AMI httpd * Up to
(excluding)
2.4.53-1.96.amzn1
运行在以下环境
系统 debian_10 apache2 * Up to
(including)
2.4.38-3+deb10u7
运行在以下环境
系统 debian_11 apache2 * Up to
(excluding)
2.4.53-1~deb11u1
运行在以下环境
系统 debian_12 apache2 * Up to
(including)
2.4.52-1
运行在以下环境
系统 debian_9 apache2 * Up to
(excluding)
2.4.25-3+deb9u13
运行在以下环境
系统 debian_sid apache2 * Up to
(including)
2.4.52-1
运行在以下环境
系统 fedora_34 apache2 * Up to
(excluding)
2.4.53-1.fc34
运行在以下环境
系统 fedora_35 apache2 * Up to
(excluding)
2.4.53-1.fc35
运行在以下环境
系统 fedora_36 apache2 * Up to
(excluding)
2.4.53-1.fc36
运行在以下环境
系统 opensuse_Leap_15.3 apache2 * Up to
(excluding)
2.4.51-150200.3.42.1
运行在以下环境
系统 suse_12_SP5 apache2 * Up to
(excluding)
2.4.51-35.13.1
运行在以下环境
系统 ubuntu_14.04 httpd * Up to
(excluding)
2.4.7-1ubuntu4.22+esm4
运行在以下环境
系统 ubuntu_16.04 httpd * Up to
(excluding)
2.4.18-2ubuntu3.17+esm5
运行在以下环境
系统 ubuntu_18.04 httpd * Up to
(excluding)
2.4.29-1ubuntu4.22
运行在以下环境
系统 ubuntu_20.04 httpd * Up to
(excluding)
2.4.41-4ubuntu3.10
运行在以下环境
系统 ubuntu_21.10 httpd * Up to
(excluding)
2.4.48-3.1ubuntu3.3
运行在以下环境
系统 ubuntu_22.04 httpd * Up to
(excluding)
2.4.52-1ubuntu2
阿里云评分
4.8
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况