中危 MariaDB 输入验证错误漏洞

CVE编号

CVE-2022-24052

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-02-22
漏洞描述
MariaDB是MariaDB(Mariadb)基金会的一套免费开源的数据库管理系统,也是一个采用Maria存储引擎的MySQL分支版本。

MariaDB 存在输入验证错误漏洞,该漏洞源于远程攻击者可以绕过已实施的安全限制。该漏洞允许远程攻击者绕过已实施的安全限制。
解决建议
目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:

https://vigilance.fr/vulnerability/MariaDB-four-vulnerabilities-37501
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 mariadb mariadb * From
(including)
10.2.0
Up to
(excluding)
10.2.42
运行在以下环境
应用 mariadb mariadb * From
(including)
10.3.0
Up to
(excluding)
10.3.33
运行在以下环境
应用 mariadb mariadb * From
(including)
10.4.0
Up to
(excluding)
10.4.23
运行在以下环境
应用 mariadb mariadb * From
(including)
10.5.0
Up to
(excluding)
10.5.14
运行在以下环境
应用 mariadb mariadb * From
(including)
10.6.0
Up to
(excluding)
10.6.6
运行在以下环境
应用 mariadb mariadb * From
(including)
10.7.0
Up to
(excluding)
10.7.2
运行在以下环境
应用 mariadb mariadb 10.8.0 -
运行在以下环境
系统 alpine_3.12 mariadb * Up to
(excluding)
10.4.24-r0
运行在以下环境
系统 alpine_3.13 mariadb * Up to
(excluding)
10.5.15-r0
运行在以下环境
系统 alpine_3.14 mariadb * Up to
(excluding)
10.5.15-r0
运行在以下环境
系统 alpine_3.15 mariadb * Up to
(excluding)
10.6.7-r0
运行在以下环境
系统 alpine_3.16 mariadb * Up to
(excluding)
10.6.7-r0
运行在以下环境
系统 alpine_edge mariadb * Up to
(excluding)
10.6.7-r0
运行在以下环境
系统 debian_10 mariadb-10.5 * Up to
(excluding)
1:10.3.34-0+deb10u1
运行在以下环境
系统 debian_11 mariadb-10.5 * Up to
(excluding)
1:10.5.15-0+deb11u1
运行在以下环境
系统 debian_12 mariadb-10.5 * Up to
(including)
10.6.5-2
运行在以下环境
系统 debian_sid mariadb-10.5 * Up to
(including)
10.6.5-2
运行在以下环境
系统 fedora_34 mariadb * Up to
(excluding)
10.5.15-1.fc34
运行在以下环境
系统 fedora_34_Modular mariadb * Up to
(excluding)
10.5-3420220428160949.058368ca
运行在以下环境
系统 fedora_35 mariadb * Up to
(excluding)
26.4.11-1.fc35
运行在以下环境
系统 fedora_35_Modular mariadb * Up to
(excluding)
10.5-3520220428160949.f27b74a8
运行在以下环境
系统 fedora_36 mariadb * Up to
(excluding)
26.4.11-1.fc36
运行在以下环境
系统 fedora_36_Modular mariadb * Up to
(excluding)
10.5-3620220428160949.5e5ad4a0
运行在以下环境
系统 opensuse_Leap_15.3 mariadb-10.5 * Up to
(excluding)
10.5.15-150300.3.15.1
运行在以下环境
系统 opensuse_Leap_15.4 mariadb-10.5 * Up to
(excluding)
10.4.24-3.25.1
运行在以下环境
系统 suse_12_SP5 mariadb-10.5 * Up to
(excluding)
10.2.43-3.47.1
运行在以下环境
系统 ubuntu_20.04 mariadb * Up to
(excluding)
1:10.3.34-0ubuntu0.20.04.1
运行在以下环境
系统 ubuntu_21.10 mariadb * Up to
(excluding)
1:10.5.15-0ubuntu0.21.10.1
阿里云评分
6.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-122 堆缓冲区溢出
阿里云安全产品覆盖情况