gitlab gitlab 对路径名的限制不恰当(路径遍历)

CVE编号

CVE-2022-2531

利用情况

暂无

补丁情况

N/A

披露时间

2022-08-06
漏洞描述
An issue has been discovered in GitLab EE affecting all versions starting from 12.5 before 15.0.5, all versions starting from 15.1 before 15.1.4, all versions starting from 15.2 before 15.2.1. GitLab was not performing correct authentication on Grafana API under specific conditions allowing unauthenticated users to perform queries through a path traversal vulnerability.
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gitlab gitlab * From
(including)
12.5.0
Up to
(excluding)
15.0.5
运行在以下环境
应用 gitlab gitlab * From
(including)
15.1.0
Up to
(excluding)
15.1.4
运行在以下环境
应用 gitlab gitlab 15.2 -
运行在以下环境
系统 alibaba_cloud_linux_2.1903 expat * Up to
(excluding)
2.1.0-14.1.al7
运行在以下环境
系统 amazon_2 expat * Up to
(excluding)
91.7.0-2.amzn2.0.1
运行在以下环境
系统 amazon_2022 expat * Up to
(excluding)
2.4.7-1.amzn2022.0.1
运行在以下环境
系统 centos_7 expat * Up to
(excluding)
2.1.0-14.el7_9
运行在以下环境
系统 centos_8 expat * Up to
(excluding)
91.7.0-3.el8_5
运行在以下环境
系统 fedora_34 expat * Up to
(excluding)
1.0.11-3.fc34
运行在以下环境
系统 fedora_35 expat * Up to
(excluding)
1.0.11-3.fc35
运行在以下环境
系统 fedora_36 expat * Up to
(excluding)
1.0.11-3.fc36
运行在以下环境
系统 fedora_37 expat * Up to
(excluding)
1.0.11-3.fc37
运行在以下环境
系统 opensuse_Leap_15.3 expat * Up to
(excluding)
2.2.5-3.15.1
运行在以下环境
系统 oracle_7 expat * Up to
(excluding)
91.7.0-3.0.1.el7_9
运行在以下环境
系统 oracle_8 expat * Up to
(excluding)
91.7.0-3.0.1.el8_5
运行在以下环境
系统 redhat_6 expat * Up to
(excluding)
0:2.0.1-14.el6_10
运行在以下环境
系统 redhat_7 firefox * Up to
(excluding)
0:91.7.0-3.el7_9
运行在以下环境
系统 redhat_8 expat * Up to
(excluding)
91.7.0-3.el8_5
运行在以下环境
系统 suse_12_SP5 expat * Up to
(excluding)
0.19.2-14.3.1
CVSS3评分
5.3
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-22 对路径名的限制不恰当(路径遍历)
阿里云安全产品覆盖情况