中危 Expat 输入验证错误漏洞

CVE编号

CVE-2022-25315

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-02-18
漏洞描述
Expat是一款使用C语言编写的快速流式XML解析器。

Expat 存在输入验证错误漏洞,该漏洞源于 storeRawNames 中存在整数溢出。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/libexpat/libexpat/pull/559
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libexpat_project libexpat * Up to
(excluding)
2.4.5
运行在以下环境
系统 alibaba_cloud_linux_2.1903 expat * Up to
(excluding)
2.1.0-14.1.al7
运行在以下环境
系统 alpine_3.12 expat * Up to
(excluding)
2.2.10-r2
运行在以下环境
系统 alpine_3.13 expat * Up to
(excluding)
2.2.10-r4
运行在以下环境
系统 alpine_3.14 expat * Up to
(excluding)
2.4.5-r0
运行在以下环境
系统 alpine_3.15 expat * Up to
(excluding)
2.4.5-r0
运行在以下环境
系统 alpine_3.16 expat * Up to
(excluding)
2.4.5-r0
运行在以下环境
系统 alpine_3.17 expat * Up to
(excluding)
2.4.5-r0
运行在以下环境
系统 alpine_edge expat * Up to
(excluding)
2.4.5-r0
运行在以下环境
系统 amazon_2 expat * Up to
(excluding)
2.1.0-12.amzn2.0.2
运行在以下环境
系统 amazon_2022 expat * Up to
(excluding)
2.4.7-1.amzn2022.0.1
运行在以下环境
系统 amazon_AMI expat * Up to
(excluding)
2.1.0-12.26.amzn1
运行在以下环境
系统 centos_7 expat * Up to
(excluding)
2.1.0-14.el7_9
运行在以下环境
系统 centos_8 expat * Up to
(excluding)
91.7.0-3.el8_5
运行在以下环境
系统 debian_10 expat * Up to
(excluding)
2.2.6-2+deb10u3
运行在以下环境
系统 debian_11 expat * Up to
(excluding)
2.2.10-2+deb11u2
运行在以下环境
系统 debian_12 expat * Up to
(including)
2.4.4-1
运行在以下环境
系统 debian_9 expat * Up to
(excluding)
2.2.0-2+deb9u5
运行在以下环境
系统 debian_sid expat * Up to
(including)
2.4.4-1
运行在以下环境
系统 fedora_34 expat * Up to
(excluding)
2.4.6-1.fc34
运行在以下环境
系统 fedora_35 expat * Up to
(excluding)
2.4.6-1.fc35
运行在以下环境
系统 opensuse_Leap_15.3 expat * Up to
(excluding)
2.2.5-3.15.1
运行在以下环境
系统 oracle_7 expat * Up to
(excluding)
91.7.0-3.0.1.el7_9
运行在以下环境
系统 oracle_8 expat * Up to
(excluding)
91.7.0-3.0.1.el8_5
运行在以下环境
系统 redhat_6 expat * Up to
(excluding)
0:2.0.1-14.el6_10
运行在以下环境
系统 redhat_7 firefox * Up to
(excluding)
0:91.7.0-3.el7_9
运行在以下环境
系统 redhat_8 expat * Up to
(excluding)
91.7.0-3.el8_5
运行在以下环境
系统 suse_12_SP5 expat * Up to
(excluding)
2.1.0-21.18.1
运行在以下环境
系统 ubuntu_14.04 expat * Up to
(excluding)
2.1.0-4ubuntu1.4+esm6
运行在以下环境
系统 ubuntu_16.04 expat * Up to
(excluding)
2.1.0-7ubuntu0.16.04.5+esm5
运行在以下环境
系统 ubuntu_18.04 expat * Up to
(excluding)
2.2.5-3ubuntu0.7
运行在以下环境
系统 ubuntu_20.04 expat * Up to
(excluding)
2.2.9-1ubuntu0.4
运行在以下环境
系统 ubuntu_21.10 expat * Up to
(excluding)
2.4.1-2ubuntu0.3
运行在以下环境
系统 ubuntu_22.04 expat * Up to
(excluding)
2.4.5-2
运行在以下环境
系统 ubuntu_22.10 expat * Up to
(excluding)
1:1snap1-0ubuntu1
阿里云评分
4.8
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-190 整数溢出或超界折返
阿里云安全产品覆盖情况