中危 Angular正则表达式拒绝服务漏洞(CVE-2022-25844)

CVE编号

CVE-2022-25844

利用情况

暂无

补丁情况

没有补丁

披露时间

2022-05-02
漏洞描述
Angular是一款基于TypeScript的开源Web应用程序框架。
Angular 1.7.0及之后版本存在正则表达式拒绝服务漏洞,该漏洞源于程序提供了自定义的区域设置规则,允许在posPre中分配参数。攻击者可利用该漏洞导致拒绝服务。

受影响系统:
Angular Angular >= 1.7.0
解决建议
目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本:

http://angular.cn/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 angularjs angular * From
(including)
1.7.0
运行在以下环境
系统 debian_10 angular.js * Up to
(including)
1.5.10-1
运行在以下环境
系统 debian_11 angular.js * Up to
(including)
1.8.2-2
运行在以下环境
系统 debian_12 angular.js * Up to
(including)
1.8.2-2
运行在以下环境
系统 debian_9 angular.js * Up to
(including)
1.5.10-1
运行在以下环境
系统 debian_sid angular.js * Up to
(including)
1.8.2-2
运行在以下环境
系统 ubuntu_18.04 angular.js * Up to
(excluding)
1.5.10-1
阿里云评分
6.7
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    没有补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-770 不加限制或调节的资源分配
阿里云安全产品覆盖情况