中危 Buildah 安全漏洞(CVE-2022-27650)

CVE编号

CVE-2022-27650

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-04-05
漏洞描述
Buildah是一款支持构建OCI容器映像的工具。

Buildah 存在安全漏洞,该漏洞源于受影响产品使用非空默认权限错误地启动了容器。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/containers/crun/security/advisories/GHSA-wr4f-w546-m398
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 crun_project crun * Up to
(excluding)
1.4.4
运行在以下环境
应用 redhat openshift_container_platform 4.0 -
运行在以下环境
系统 alpine_3.16 crun * Up to
(excluding)
1.4.4-r0
运行在以下环境
系统 alpine_edge crun * Up to
(excluding)
1.4.4-r0
运行在以下环境
系统 debian_11 crun * Up to
(including)
0.17+dfsg-1
运行在以下环境
系统 debian_12 crun * Up to
(including)
0.17+dfsg-1.1
运行在以下环境
系统 debian_sid crun * Up to
(including)
0.17+dfsg-1.1
运行在以下环境
系统 fedora_34 crun * Up to
(excluding)
1.4.4-1.fc34
阿里云评分
4.8
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-276 缺省权限不正确
阿里云安全产品覆盖情况