中危 golang go http请求的解释不一致性(http请求私运)

CVE编号

CVE-2022-2880

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-10-14
漏洞描述
Requests forwarded by ReverseProxy include the raw query parameters from the inbound request, including unparseable parameters rejected by net/http. This could permit query parameter smuggling when a Go proxy forwards a parameter with an unparseable value. After fix, ReverseProxy sanitizes the query parameters in the forwarded query when the outbound request's Form field is set after the ReverseProxy. Director function returns, indicating that the proxy has parsed the query parameters. Proxies which do not parse query parameters continue to forward the original query parameters unchanged.
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 golang go * Up to
(excluding)
1.18.7
运行在以下环境
应用 golang go * From
(including)
1.19.0
Up to
(excluding)
1.19.2
运行在以下环境
系统 alibaba_cloud_linux_3 golang * Up to
(excluding)
1.18.9-1.0.1.al8
运行在以下环境
系统 alma_linux_8 git-lfs * Up to
(excluding)
3.2.0-2.el8
运行在以下环境
系统 alma_linux_9 golang * Up to
(excluding)
1.18.9-1.el9_1
运行在以下环境
系统 alpine_3.16 go * Up to
(excluding)
1.18.7-r0
运行在以下环境
系统 alpine_3.17 go * Up to
(excluding)
1.19.2-r0
运行在以下环境
系统 alpine_3.18 go * Up to
(excluding)
1.19.2-r0
运行在以下环境
系统 alpine_3.19 go * Up to
(excluding)
1.19.2-r0
运行在以下环境
系统 amazon_2 golang * Up to
(excluding)
1.18.9-1.amzn2.0.2
运行在以下环境
系统 amazon_2022 lua * Up to
(excluding)
5.4.4-3.amzn2022
运行在以下环境
系统 amazon_2023 golang * Up to
(excluding)
1.19.8-1.amzn2023.0.1
运行在以下环境
系统 anolis_os_8 grafana * Up to
(excluding)
7.5.15-4.0.2
运行在以下环境
系统 debian_12 golang-1.19 * Up to
(excluding)
1.19.2-1
运行在以下环境
系统 fedora_35 lua * Up to
(excluding)
5.4.4-3.fc35
运行在以下环境
系统 fedora_36 lua * Up to
(excluding)
5.4.4-3.fc36
运行在以下环境
系统 fedora_37 golang * Up to
(excluding)
1.19.2-1.fc37
运行在以下环境
系统 fedora_EPEL_7 golang * Up to
(excluding)
1.18.9-1.el7
运行在以下环境
系统 opensuse_Leap_15.3 go1.19 * Up to
(excluding)
1.19.2-150000.1.12.1
运行在以下环境
系统 opensuse_Leap_15.4 go1.18 * Up to
(excluding)
1.18.7-150000.1.34.1
运行在以下环境
系统 opensuse_Leap_15.5 go1.18-openssl * Up to
(excluding)
1.18.10.1-150000.1.9.1
运行在以下环境
系统 oracle_8 git-lfs * Up to
(excluding)
3.2.0-2.el8
运行在以下环境
系统 oracle_9 golang * Up to
(excluding)
1.18.9-1.el9_1
运行在以下环境
系统 redhat_8 grafana * Up to
(excluding)
7.5.15-4.el8
运行在以下环境
系统 redhat_9 golang * Up to
(excluding)
1.18.9-1.el9_1
运行在以下环境
系统 rocky_linux_9 golang * Up to
(excluding)
1.18.9-1.el9_1
运行在以下环境
系统 ubuntu_18.04 golang-1.18 * Up to
(excluding)
1.18.1-1ubuntu1~18.04.4
运行在以下环境
系统 ubuntu_20.04 golang-1.13 * Up to
(excluding)
1.16.2-0ubuntu1~20.04.1
阿里云评分
6.3
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-444 HTTP请求的解释不一致性(HTTP请求私运)
阿里云安全产品覆盖情况