高危 GitLab CE/EE import api 远程代码执行漏洞(CVE-2022-2992)

CVE编号

CVE-2022-2992

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-08-30
漏洞描述
2022年8月30日,Gitlab 官方发布安全通告,披露 CVE-2022-2992 GitLab CE/EE import api 远程代码执行漏洞。攻击者在登录后具有import权限的情况下可构造恶意请求执行任意代码,控制服务器。

影响版本
11.10 <= GitLab CE/EE < 15.1.6
15.2 <= GitLab CE/EE < 15.2.4
15.3 <= GitLab CE/EE < 15.3.2

安全版本
GitLab CE/EE 15.1.6
GitLab CE/EE 15.2.4
GitLab CE/EE 15.3.2
解决建议
Gitlab 官方已发布安全更新,请尽快升级更新。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gitlab gitlab * From
(including)
11.10
Up to
(excluding)
15.1.6
运行在以下环境
应用 gitlab gitlab * From
(including)
15.2
Up to
(excluding)
15.2.4
运行在以下环境
应用 gitlab gitlab * From
(including)
15.3
Up to
(excluding)
15.3.2
阿里云评分
8.0
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    普通权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-77 在命令中使用的特殊元素转义处理不恰当(命令注入)
CWE-94 对生成代码的控制不恰当(代码注入)
阿里云安全产品覆盖情况