中危 Apache HTTP Server 资源管理错误漏洞(CVE-2022-30522)

CVE编号

CVE-2022-30522

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-06-10
漏洞描述
Apache HTTP Server是美国阿帕奇(Apache)基金会的一款开源网页服务器。该服务器具有快速、可靠且可通过简单的API进行扩充的特点。

Apache HTTP Server 2.4.53 存在资源管理错误漏洞,该漏洞源于当mod_sed输入过大时 mod_sed可能会分配过大的内存并触发中止。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://httpd.apache.org/security/vulnerabilities_24.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache http_server * Up to
(including)
2.4.53
运行在以下环境
系统 alpine_3.13 apache2 * Up to
(excluding)
2.4.54-r0
运行在以下环境
系统 alpine_3.14 apache2 * Up to
(excluding)
2.4.54-r0
运行在以下环境
系统 alpine_3.15 apache2 * Up to
(excluding)
2.4.54-r0
运行在以下环境
系统 alpine_3.16 apache2 * Up to
(excluding)
2.4.54-r0
运行在以下环境
系统 alpine_edge apache2 * Up to
(excluding)
2.4.54-r0
运行在以下环境
系统 debian_10 apache2 * Up to
(including)
2.4.38-3+deb10u7
运行在以下环境
系统 debian_11 apache2 * Up to
(including)
2.4.53-1~deb11u1
运行在以下环境
系统 debian_12 apache2 * Up to
(including)
2.4.53-2
运行在以下环境
系统 debian_9 apache2 * Up to
(including)
2.4.25-3+deb9u9
运行在以下环境
系统 debian_sid apache2 * Up to
(including)
2.4.53-2
运行在以下环境
系统 fedora_35 apache2 * Up to
(excluding)
2.4.54-1.fc35
运行在以下环境
系统 fedora_36 apache2 * Up to
(excluding)
2.4.54-3.fc36
运行在以下环境
系统 suse_12_SP5 apache2 * Up to
(excluding)
2.4.51-35.19.1
运行在以下环境
系统 ubuntu_14.04 apache2 * Up to
(excluding)
2.4.7-1ubuntu4.22+esm5
运行在以下环境
系统 ubuntu_16.04 apache2 * Up to
(excluding)
2.4.18-2ubuntu3.17+esm6
运行在以下环境
系统 ubuntu_18.04 apache2 * Up to
(excluding)
2.4.29-1ubuntu4.24
运行在以下环境
系统 ubuntu_20.04 apache2 * Up to
(excluding)
2.4.41-4ubuntu3.12
运行在以下环境
系统 ubuntu_21.10 apache2 * Up to
(excluding)
2.4.48-3.1ubuntu3.5
运行在以下环境
系统 ubuntu_22.04 apache2 * Up to
(excluding)
2.4.52-1ubuntu4.1
阿里云评分
4.8
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-770 不加限制或调节的资源分配
阿里云安全产品覆盖情况