高危 Spring Security forward/include 认证绕过漏洞(CVE-2022-31692)

CVE编号

CVE-2022-31692

利用情况

POC 已公开

补丁情况

官方补丁

披露时间

2022-11-01
漏洞描述
CVE-2022-31692 中,在Spring Security受影响版本范围内,在使用forward/include进行转发的情况下可能导致权限绕过。阿里云安全团队已完成相关利用分析,漏洞利用需要依赖具体代码逻辑,实际风险较低。

受影响版本:
5.7.0 <= Spring Security <= 5.7.4
5.6.0 <= Spring Security <= 5.6.8

安全版本:
Spring Security >= 5.7.5
Spring Security >= 5.6.9

解决建议
1、建议升级至安全版本及其以上
2、若无法升级,建议按照 https://tanzu.vmware.com/security/cve-2022-31692 中相关方案自行排查改造。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 vmware spring_security * From
(including)
5.6.0
Up to
(excluding)
5.6.9
运行在以下环境
应用 vmware spring_security * From
(including)
5.7.0
Up to
(excluding)
5.7.5
阿里云评分
7.0
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    越权影响
  • EXP成熟度
    POC 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-287 认证机制不恰当
CWE-863 授权机制不正确
阿里云安全产品覆盖情况