中危 MariaDB 资源管理错误漏洞(CVE-2022-32081)

CVE编号

CVE-2022-32081

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-07-02
漏洞描述
MariaDB是Mariadb基金会的一套免费开源的数据库管理系统,也是一个采用Maria存储引擎的MySQL分支版本。

MariaDB v10.4 版本到 v10.7 版本存在资源管理错误漏洞,该漏洞源于发现在 /storage/innobase/handler/handler0alter.cc 页面的 prepare_inplace_add_virtual 中存在内存中毒。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://jira.mariadb.org/browse/MDEV-26420
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 mariadb mariadb * From
(including)
10.4.0
Up to
(excluding)
10.4.25
运行在以下环境
应用 mariadb mariadb * From
(including)
10.5.0
Up to
(excluding)
10.5.16
运行在以下环境
应用 mariadb mariadb * From
(including)
10.6.0
Up to
(excluding)
10.6.8
运行在以下环境
应用 mariadb mariadb * From
(including)
10.7.0
Up to
(excluding)
10.7.4
运行在以下环境
系统 alpine_3.13 mariadb * Up to
(excluding)
10.5.17-r0
运行在以下环境
系统 alpine_3.14 mariadb * Up to
(excluding)
10.5.17-r0
运行在以下环境
系统 alpine_3.15 mariadb * Up to
(excluding)
10.6.9-r0
运行在以下环境
系统 alpine_3.16 mariadb * Up to
(excluding)
10.6.9-r0
运行在以下环境
系统 alpine_3.17 mariadb * Up to
(excluding)
10.6.9-r0
运行在以下环境
系统 alpine_edge mariadb * Up to
(excluding)
10.6.9-r0
运行在以下环境
系统 amazon_2022 mariadb * Up to
(excluding)
10.5.16-1.amzn2022.0.5
运行在以下环境
系统 debian_10 mariadb * Up to
(including)
10.3.34-0+deb10u1
运行在以下环境
系统 debian_11 mariadb * Up to
(excluding)
1:10.5.18-0+deb11u1
运行在以下环境
系统 debian_12 mariadb * Up to
(including)
10.6.8-1
运行在以下环境
系统 debian_sid mariadb * Up to
(including)
10.6.8-1
运行在以下环境
系统 fedora_35 mariadb * Up to
(excluding)
26.4.13-1.fc35
运行在以下环境
系统 fedora_35_Modular mariadb * Up to
(excluding)
10.8-3520221023061040.f27b74a8
运行在以下环境
系统 fedora_36 mariadb * Up to
(excluding)
26.4.13-1.fc36
运行在以下环境
系统 fedora_36_Modular mariadb * Up to
(excluding)
10.9-3620221023053557.F36
运行在以下环境
系统 fedora_37 mariadb * Up to
(excluding)
26.4.13-1.fc37
运行在以下环境
系统 fedora_37_Modular mariadb * Up to
(excluding)
10.8-3720221023061040.9e842022
运行在以下环境
系统 ubuntu_20.04 mariadb * Up to
(excluding)
1:10.3.37-0ubuntu0.20.04.1
运行在以下环境
系统 ubuntu_22.04 mariadb * Up to
(excluding)
1:10.6.11-0ubuntu0.22.04.1
运行在以下环境
系统 ubuntu_22.10 mariadb * Up to
(excluding)
1:10.6.9-1
阿里云评分
6.3
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
CWE-416 释放后使用
阿里云安全产品覆盖情况