中危 curl 安全漏洞(CVE-2022-32221)

CVE编号

CVE-2022-32221

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-10-27
漏洞描述

curl是一款用于从服务器传输数据或向服务器传输数据的工具。

curl存在安全漏洞。攻击者利用该漏洞发送错误数据。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://curl.se/docs/CVE-2022-32221.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 haxx curl * Up to
(excluding)
7.86.0
运行在以下环境
系统 alpine_3.15 curl * Up to
(excluding)
7.80.0-r4
运行在以下环境
系统 alpine_3.16 curl * Up to
(excluding)
7.83.1-r4
运行在以下环境
系统 alpine_3.17 curl * Up to
(excluding)
7.86.0-r0
运行在以下环境
系统 alpine_3.18 curl * Up to
(excluding)
7.86.0-r0
运行在以下环境
系统 alpine_edge curl * Up to
(excluding)
7.86.0-r0
运行在以下环境
系统 amazon_2 curl * Up to
(excluding)
7.79.1-7.amzn2.0.1
运行在以下环境
系统 amazon_2022 curl * Up to
(excluding)
7.86.0-1.amzn2022.0.1
运行在以下环境
系统 amazon_2023 curl * Up to
(excluding)
7.87.0-2.amzn2023.0.2
运行在以下环境
系统 debian_10 curl * Up to
(excluding)
7.64.0-4+deb10u4
运行在以下环境
系统 debian_11 curl * Up to
(excluding)
7.74.0-1.3+deb11u5
运行在以下环境
系统 debian_12 curl * Up to
(excluding)
7.86.0-1
运行在以下环境
系统 debian_sid curl * Up to
(excluding)
7.86.0-1
运行在以下环境
系统 fedora_35 curl-debugsource * Up to
(excluding)
7.79.1-7.fc35
运行在以下环境
系统 fedora_36 curl-debugsource * Up to
(excluding)
7.82.0-9.fc36
运行在以下环境
系统 fedora_37 curl-debugsource * Up to
(excluding)
7.85.0-2.fc37
运行在以下环境
系统 fedora_EPEL_7 davix * Up to
(excluding)
0.8.3-1.el7
运行在以下环境
系统 fedora_EPEL_8 davix * Up to
(excluding)
0.8.3-1.el8
运行在以下环境
系统 kylinos_aarch64_V10SP1 curl * Up to
(excluding)
7.71.1-19.ky10
运行在以下环境
系统 kylinos_loongarch64_V10SP1 curl * Up to
(excluding)
7.71.1-19.a.ky10
运行在以下环境
系统 kylinos_x86_64_V10SP1 curl * Up to
(excluding)
7.71.1-19.ky10
运行在以下环境
系统 opensuse_5.2 libcurl4 * Up to
(excluding)
7.66.0-150200.4.42.1
运行在以下环境
系统 opensuse_Leap_15.3 libcurl4 * Up to
(excluding)
7.66.0-150200.4.42.1
运行在以下环境
系统 opensuse_Leap_15.4 libcurl4 * Up to
(excluding)
7.79.1-150400.5.9.1
运行在以下环境
系统 oracle_9 oraclelinux-release * Up to
(excluding)
7.76.1-19.el9_1.1
运行在以下环境
系统 redhat_9 curl-debugsource * Up to
(excluding)
7.76.1-19.el9_1.1
运行在以下环境
系统 suse_12_SP5 curl * Up to
(excluding)
7.60.0-11.49.1
运行在以下环境
系统 ubuntu_18.04 curl * Up to
(excluding)
7.58.0-2ubuntu3.21
运行在以下环境
系统 ubuntu_20.04 curl * Up to
(excluding)
7.68.0-1ubuntu2.14
运行在以下环境
系统 ubuntu_22.04 curl * Up to
(excluding)
7.81.0-1ubuntu1.6
运行在以下环境
系统 ubuntu_22.10 curl * Up to
(excluding)
7.85.0-1ubuntu0.1
运行在以下环境
系统 unionos_d curl * Up to
(excluding)
7.64.1.13-deepin1
运行在以下环境
系统 unionos_e curl * Up to
(excluding)
curl-7.71.1-19.up3.uel20
阿里云评分
4.6
  • 攻击路径
    N/A
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-440 预期行为违背
CWE-668 将资源暴露给错误范围
阿里云安全产品覆盖情况