imagemagick imagemagick 整数溢出或超界折返

CVE编号

CVE-2022-32546

利用情况

暂无

补丁情况

N/A

披露时间

2022-06-17
漏洞描述
A vulnerability was found in ImageMagick, causing an outside the range of representable values of type 'unsigned long' at coders/pcl.c, when crafted or untrusted input is processed. This leads to a negative impact to application availability or other problems related to undefined behavior.
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 fedoraproject extra_packages_for_enterprise_linux 8.0 -
运行在以下环境
应用 imagemagick imagemagick * Up to
(excluding)
6.9.12-44
运行在以下环境
应用 imagemagick imagemagick * From
(including)
7.1.0
Up to
(excluding)
7.1.0-29
运行在以下环境
系统 debian_10 imagemagick * Up to
(including)
6.9.10.23+dfsg-2.1+deb10u1
运行在以下环境
系统 debian_11 imagemagick * Up to
(including)
6.9.11.60+dfsg-1.3
运行在以下环境
系统 debian_12 imagemagick * Up to
(including)
6.9.11.60+dfsg-1.3
运行在以下环境
系统 debian_9 imagemagick * Up to
(including)
6.9.7.4+dfsg-11+deb9u8
运行在以下环境
系统 debian_sid imagemagick * Up to
(including)
6.9.11.60+dfsg-1.3
CVSS3评分
7.8
  • 攻击路径
    本地
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
    需要
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-190 整数溢出或超界折返
阿里云安全产品覆盖情况