libtiff libtiff 跨界内存写

CVE编号

CVE-2022-3570

利用情况

暂无

补丁情况

N/A

披露时间

2022-10-22
漏洞描述
Multiple heap buffer overflows in tiffcrop.c utility in libtiff library Version 4.4.0 allows attacker to trigger unsafe or out of bounds memory access via crafted TIFF image file which could result into application crash, potential information disclosure or any other context-dependent impact
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libtiff libtiff * From
(including)
3.9.0
Up to
(including)
4.4.0
运行在以下环境
系统 debian_10 tiff * Up to
(including)
4.1.0+git191117-2~deb10u4
运行在以下环境
系统 debian_11 tiff * Up to
(including)
4.2.0-1+deb11u1
运行在以下环境
系统 debian_12 tiff * Up to
(including)
4.4.0-4
运行在以下环境
系统 debian_sid tiff * Up to
(including)
4.4.0-4
运行在以下环境
系统 ubuntu_14.04 tiff * Up to
(excluding)
4.0.3-7ubuntu0.11+esm5
运行在以下环境
系统 ubuntu_16.04 tiff * Up to
(excluding)
4.0.6-1ubuntu0.8+esm6
运行在以下环境
系统 ubuntu_18.04 tiff * Up to
(excluding)
4.0.9-5ubuntu0.8
运行在以下环境
系统 ubuntu_20.04 tiff * Up to
(excluding)
4.1.0+git191117-2ubuntu0.20.04.6
运行在以下环境
系统 ubuntu_22.04 tiff * Up to
(excluding)
4.3.0-6ubuntu0.2
运行在以下环境
系统 ubuntu_22.10 tiff * Up to
(excluding)
4.4.0-4ubuntu3.1
CVSS3评分
9.8
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况