高危 Apache Geode JMX over RMI 反序列化漏洞(CVE-2022-37022)

CVE编号

CVE-2022-37022

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-08-31
漏洞描述
Apache Geode 是一个数据管理平台,可在广泛分布的云架构中提供对数据密集型应用程序的实时、一致的访问。 2022年8月30日,Apache发布安全公告,修复了一个CVE-2022-37022 Apache Geode 反序列化漏洞。当在Java 11上使用JMX over RMI时,1.12.2和1.13.2及以下版本的Apache Geode容易受到不可信数据缺陷反序列化的影响,可能造成远程代码执行。

影响版本:
Apache Geode <=1.12.2
Apache Geode <=1.13.2

安全版本:
Apache Geode 1.15
解决建议
官方已发布安全更新,建议升级至安全版本及其以上。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache geode * Up to
(including)
1.12.2
运行在以下环境
应用 apache geode * From
(including)
1.13.0
Up to
(including)
1.13.2
阿里云评分
7.0
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-502 可信数据的反序列化
阿里云安全产品覆盖情况