高危 XKCP 输入验证错误漏洞(CVE-2022-37454)

CVE编号

CVE-2022-37454

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-10-21
漏洞描述
XKCP是XKCP开源的一个扩展 Keccak 代码包。

XKCP SHA-3存在安全漏洞,该漏洞源于攻击者可以通过其sponge函数接口实现整数溢出导致执行任意代码或消除预期的加密属性。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/XKCP/XKCP/commit/fdc6fef075f4e81d6b1bc38364248975e08e340a
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 extended_keccak_code_package_project extended_keccak_code_package - -
运行在以下环境
系统 alpine_3.14 php * Up to
(excluding)
7.4.33-r0
运行在以下环境
系统 alpine_3.15 php * Up to
(excluding)
7.4.33-r0
运行在以下环境
系统 alpine_3.16 php * Up to
(excluding)
3.10.9-r0
运行在以下环境
系统 alpine_3.17 php * Up to
(excluding)
3.10.9-r0
运行在以下环境
系统 alpine_edge php * Up to
(excluding)
8.2.0_rc5-r0
运行在以下环境
系统 amazon_2 php * Up to
(excluding)
3.7.15-1.amzn2.0.2
运行在以下环境
系统 amazon_2022 php * Up to
(excluding)
8.1.12-1.amzn2022.0.1
运行在以下环境
系统 amazon_AMI php * Up to
(excluding)
3.6.12-1.23.amzn1
运行在以下环境
系统 debian_10 php * Up to
(excluding)
3.7.3-2+deb10u4
运行在以下环境
系统 debian_11 php * Up to
(including)
3.9.2-1
运行在以下环境
系统 debian_12 php * Up to
(including)
3.10.8-3
运行在以下环境
系统 debian_sid php * Up to
(including)
3.9.13-1
运行在以下环境
系统 fedora_35 php * Up to
(excluding)
3.6.15-14.fc35
运行在以下环境
系统 fedora_36 php * Up to
(excluding)
3.7.15-2.fc36
运行在以下环境
系统 fedora_37 php * Up to
(excluding)
3.6.15-14.fc37
运行在以下环境
系统 fedora_38 php * Up to
(excluding)
3.8.15-2.fc38
运行在以下环境
系统 suse_12_SP5 php * Up to
(excluding)
3.6.15-32.2
运行在以下环境
系统 ubuntu_18.04 php * Up to
(excluding)
7.2.24-0ubuntu0.18.04.15
运行在以下环境
系统 ubuntu_20.04 php * Up to
(excluding)
7.4.3-4ubuntu2.15
运行在以下环境
系统 ubuntu_22.04 php * Up to
(excluding)
3.10.6-1~22.04.2
运行在以下环境
系统 ubuntu_22.10 php * Up to
(excluding)
8.1.7-1ubuntu3.1
阿里云评分
7.0
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-190 整数溢出或超界折返
阿里云安全产品覆盖情况