高危 Apache Dubbo Hessian-Lite 远程代码执行漏洞(CVE-2022-39198)

CVE编号

CVE-2022-39198

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-10-18
漏洞描述
Dubbo是一个高性能优秀的服务框架。CVE-2022-39198中,在Dubbo Hessian-Lite 3.2.12 之前版本中存在反序列化漏洞,攻击者在可访问到dubbo服务的情况下可构造恶意请求触发反序列化,执行任意代码。

影响范围
Apache Dubbo 2.7.x <= 2.7.17
Apache Dubbo 3.0.x <= 3.0.11
Apache Dubbo 3.1.x <= 3.1.0

安全版本
Apache Dubbo 2.7.18
Apache Dubbo 3.0.12
Apache Dubbo 3.1.1
解决建议
官方已发布安全更新,请尽快升级至安全版本及其以上。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache dubbo * From
(including)
2.7.0
Up to
(including)
2.7.17
运行在以下环境
应用 apache dubbo * From
(including)
3.0.0
Up to
(including)
3.0.11
运行在以下环境
应用 apache dubbo 3.1.0 -
阿里云评分
7.0
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-502 可信数据的反序列化
阿里云安全产品覆盖情况