中危 libexpat 资源管理错误漏洞(CVE-2022-40674)

CVE编号

CVE-2022-40674

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-09-14
漏洞描述
libexpat是一款使用C语言编写的流式XML解析器。

libexpat 2.4.9之前的版本存在安全漏洞,该漏洞源于其xmlparse.c组件中的doContent函数存在释放后重用。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/libexpat/libexpat/commit/a976e32abd257728a51dc55cf3d4ebee5b853459
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libexpat_project libexpat * Up to
(excluding)
2.4.9
运行在以下环境
系统 alibaba_cloud_linux_2.1903 expat * Up to
(excluding)
2.1.0-15.1.al7
运行在以下环境
系统 alpine_3.13 expat * Up to
(excluding)
2.2.10-r7
运行在以下环境
系统 alpine_3.14 expat * Up to
(excluding)
2.4.9-r0
运行在以下环境
系统 alpine_3.15 expat * Up to
(excluding)
2.4.9-r0
运行在以下环境
系统 alpine_3.16 expat * Up to
(excluding)
2.4.9-r0
运行在以下环境
系统 alpine_3.17 expat * Up to
(excluding)
2.4.9-r0
运行在以下环境
系统 alpine_edge expat * Up to
(excluding)
2.4.9-r0
运行在以下环境
系统 amazon_2 expat * Up to
(excluding)
2.1.0-15.amzn2.0.1
运行在以下环境
系统 amazon_2022 expat * Up to
(excluding)
2.4.9-1.amzn2022.0.1
运行在以下环境
系统 amazon_AMI expat * Up to
(excluding)
2.1.0-15.32.amzn1
运行在以下环境
系统 centos_8 expat * Up to
(excluding)
102.3.0-7.el8_6
运行在以下环境
系统 debian_10 expat * Up to
(excluding)
2.2.6-2+deb10u5
运行在以下环境
系统 debian_11 expat * Up to
(excluding)
2.2.10-2+deb11u4
运行在以下环境
系统 debian_12 expat * Up to
(including)
2.4.8-1
运行在以下环境
系统 debian_sid expat * Up to
(including)
2.4.8-1
运行在以下环境
系统 fedora_35 expat * Up to
(excluding)
2.4.9-1.fc35
运行在以下环境
系统 fedora_36 expat * Up to
(excluding)
2.4.9-1.fc36
运行在以下环境
系统 fedora_37 expat * Up to
(excluding)
2.4.9-1.fc37
运行在以下环境
系统 redhat_6 expat * Up to
(excluding)
0:2.0.1-15.el6_10
运行在以下环境
系统 redhat_7 thunderbird * Up to
(excluding)
0:102.3.0-4.el7_9
运行在以下环境
系统 redhat_8 expat * Up to
(excluding)
102.3.0-7.el8_6
运行在以下环境
系统 suse_12_SP5 expat * Up to
(excluding)
2.1.0-21.25.1
运行在以下环境
系统 ubuntu_16.04 expat * Up to
(excluding)
2.1.0-7ubuntu0.16.04.5+esm6
运行在以下环境
系统 ubuntu_18.04 expat * Up to
(excluding)
107.0+build2-0ubuntu0.18.04.1
运行在以下环境
系统 ubuntu_20.04 expat * Up to
(excluding)
107.0+build2-0ubuntu0.20.04.1
运行在以下环境
系统 ubuntu_22.04 expat * Up to
(excluding)
2.4.7-1ubuntu0.1
运行在以下环境
系统 ubuntu_22.10 expat * Up to
(excluding)
2.4.8-2
阿里云评分
6.8
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-416 释放后使用
阿里云安全产品覆盖情况