中危 Django ReDos漏洞

CVE编号

CVE-2022-41323

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-10-16
漏洞描述
Django是Django基金会的一套基于Python语言的开源Web应用框架。该框架包括面向对象的映射器、视图系统、模板系统等。
4.1.2、4.0.8及3.2.16以前的版本中由于未对locale参数进行正则转义,国际化URL处理过程可能受到拒绝服务攻击。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 djangoproject django * From
(including)
3.2
Up to
(excluding)
3.2.16
运行在以下环境
应用 djangoproject django * From
(including)
4.0
Up to
(excluding)
4.0.8
运行在以下环境
应用 djangoproject django * From
(including)
4.1
Up to
(excluding)
4.1.2
运行在以下环境
系统 alpine_3.16 py3-django * Up to
(excluding)
3.2.16-r0
运行在以下环境
系统 alpine_3.17 py3-django * Up to
(excluding)
3.2.16-r0
运行在以下环境
系统 alpine_3.18 py3-django * Up to
(excluding)
3.2.16-r0
运行在以下环境
系统 alpine_3.19 py3-django * Up to
(excluding)
3.2.16-r0
运行在以下环境
系统 debian_10 python-django * Up to
(excluding)
1.11.29-1+deb10u10
运行在以下环境
系统 debian_11 python-django * Up to
(excluding)
2.2.28-1~deb11u1
运行在以下环境
系统 debian_12 python-django * Up to
(excluding)
3.2.16-1
运行在以下环境
系统 fedora_36 python-django3 * Up to
(excluding)
3.2.18-1.fc36
运行在以下环境
系统 fedora_37 python-django * Up to
(excluding)
4.0.10-1.fc37
运行在以下环境
系统 fedora_38 python-django * Up to
(excluding)
4.0.10-1.fc38
运行在以下环境
系统 fedora_EPEL_8 python-django3 * Up to
(excluding)
3.2.18-1.el8
运行在以下环境
系统 opensuse_Leap_15.3 python3-Django * Up to
(excluding)
2.2.28-bp153.2.3.1
运行在以下环境
系统 opensuse_Leap_15.4 python3-Django * Up to
(excluding)
2.2.28-bp154.2.6.1
运行在以下环境
系统 rocky_linux_8 libdb-cxx * Up to
(excluding)
5.3.28-42.el8_4
运行在以下环境
系统 ubuntu_20.04 python-django * Up to
(excluding)
2.2.12-1ubuntu0.14
运行在以下环境
系统 ubuntu_22.04 python-django * Up to
(excluding)
3.2.12-2ubuntu1.3
运行在以下环境
系统 ubuntu_22.10 python-django * Up to
(excluding)
3.2.15-1ubuntu1
阿里云评分
6.2
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-Other
阿里云安全产品覆盖情况