严重 Apache Commons JXPath 远程代码执行漏洞(CVE-2022-41852)

CVE编号

CVE-2022-41852

利用情况

EXP 已公开

补丁情况

没有补丁

披露时间

2022-10-07
该漏洞EXP已公开传播,漏洞利用成本极低,建议您立即关注并修复。
漏洞描述
Apache JXPath 在解析用户提供的XPath表达式时,若使用了JXPathContext中除compile和compilePath之外的函数来解析XPath表达式时,会导致远程代码执行漏洞。

官方未针对 CVE-2022-41852 Apache Commons JXPath 远程代码执行漏洞发布安全更新。
解决建议
建议自行排查相关代码,或不使用Apache JXPath来进行XPath解析。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache commons_jxpath * Up to
(including)
1.3
运行在以下环境
系统 debian_10 apache-commons-jxpath * Up to
(including)
1.3-9
运行在以下环境
系统 debian_11 apache-commons-jxpath * Up to
(including)
1.3-10
运行在以下环境
系统 debian_12 apache-commons-jxpath * Up to
(including)
1.3-10
运行在以下环境
系统 debian_sid apache-commons-jxpath * Up to
(including)
1.3-10
阿里云评分
9.8
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    EXP 已公开
  • 补丁情况
    没有补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-470 使用外部可控制的输入来选择类或代码(不安全的反射)
阿里云安全产品覆盖情况