严重 Apache Commons Text StringLookup 远程代码执行漏洞(CVE-2022-42889)

CVE编号

CVE-2022-42889

利用情况

EXP 已公开

补丁情况

官方补丁

披露时间

2022-10-13
该漏洞EXP已公开传播,漏洞利用成本极低,建议您立即关注并修复。
漏洞描述
Apache Commons Text 1.10.0 版本之前允许对文本进行相关的变量解析。CVE-2022-42889 中,在Apache Commons Text 1.5 ~1.9 版本中,攻击者可构造恶意文本,使得Apache Commons Text 在解析时执行任意代码,控制服务器。漏洞利用需要具体代码依赖。

影响版本
1.5 <= Apache Commons Text <= 1.9

安全版本
Apache Commons Text 1.10.0
解决建议
官方已发布安全更新,请尽快升级至安全版本及其以上。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache commons_text * From
(including)
1.5
Up to
(excluding)
1.10.0
运行在以下环境
系统 debian_11 commons-text * Up to
(including)
1.9-1
运行在以下环境
系统 debian_12 commons-text * Up to
(including)
1.9-2
运行在以下环境
系统 debian_sid commons-text * Up to
(including)
1.9-2
阿里云评分
9.9
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    EXP 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-146 表达式/命令分隔符转义处理不恰当
CWE-94 对生成代码的控制不恰当(代码注入)
阿里云安全产品覆盖情况