高危 Apache Commons BCEL 缓冲区错误漏洞(CVE-2022-42920)

CVE编号

CVE-2022-42920

利用情况

暂无

补丁情况

官方补丁

披露时间

2022-11-09
漏洞描述
Apache Commons BCEL是美国阿帕奇(Apache)基金会的一个字节代码工程库。旨在为用户提供分析、创建和操作(二进制)Java类的便捷方式。

Apache Commons BCEL存在缓冲区错误漏洞,该漏洞源于存在越界写入问题,导致API可以用于生成任意字节码。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://lists.apache.org/thread/lfxk7q8qmnh5bt9jm6nmjlv5hsxjhrz4
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache commons_bcel * Up to
(excluding)
6.6.0
运行在以下环境
系统 debian_10 bcel * Up to
(excluding)
6.2-1+deb10u1
运行在以下环境
系统 debian_11 bcel * Up to
(excluding)
6.5.0-1+deb11u1
运行在以下环境
系统 fedora_35 bcel * Up to
(excluding)
6.4.1-10.fc35
运行在以下环境
系统 fedora_36 bcel * Up to
(excluding)
6.4.1-10.fc36
运行在以下环境
系统 fedora_37 bcel * Up to
(excluding)
6.5.0-3.fc37
运行在以下环境
系统 suse_12_SP5 bcel * Up to
(excluding)
5.2-28.3.1
阿里云评分
7.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况