中危 Oracle Java SE 安全漏洞

CVE编号

CVE-2023-21954

利用情况

暂无

补丁情况

官方补丁

披露时间

2023-04-19
漏洞描述
Oracle Java SE是美国甲骨文(Oracle)公司的一款用于开发和部署桌面、服务器以及嵌入设备和实时环境中的Java应用程序。Oracle Java SE 8u361、8u361-perf、11.0.18、17.0.6版本, Oracle GraalVM Enterprise Edition product of Oracle Java SE (component: Hotspot) 20.3.9、21.3.5 和 22.3.1版本存在安全漏洞,攻击者利用该漏洞可以对关键数据进行未授权访问或对所有 Oracle Java SE、Oracle GraalVM Enterprise Edition可访问数据的完全访问。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 oracle graalvm 20.3.9 -
运行在以下环境
应用 oracle graalvm 21.3.5 -
运行在以下环境
应用 oracle graalvm 22.3.1 -
运行在以下环境
应用 oracle jdk 1.8.0 -
运行在以下环境
应用 oracle jdk 11.0.18 -
运行在以下环境
应用 oracle jdk 17.0.6 -
运行在以下环境
应用 oracle jre 1.8.0 -
运行在以下环境
应用 oracle jre 11.0.18 -
运行在以下环境
应用 oracle jre 17.0.6 -
运行在以下环境
系统 alibaba_cloud_linux_2.1903 java-11-openjdk-demo * Up to
(excluding)
1.8.0.372.b07-1.1.al7
运行在以下环境
系统 alpine_3.15 openjdk11 * Up to
(excluding)
11.0.19_p7-r0
运行在以下环境
系统 alpine_3.16 openjdk11 * Up to
(excluding)
11.0.19_p7-r0
运行在以下环境
系统 alpine_3.17 openjdk11 * Up to
(excluding)
11.0.19_p7-r0
运行在以下环境
系统 alpine_3.18 openjdk11 * Up to
(excluding)
11.0.19_p7-r0
运行在以下环境
系统 alpine_edge openjdk11 * Up to
(excluding)
11.0.19_p7-r0
运行在以下环境
系统 amazon_2 java-11-openjdk * Up to
(excluding)
1.8.0-amazon-corretto-devel-1.8.0_372.b07-1.amzn2
运行在以下环境
系统 amazon_2023 java-11-amazon-corretto * Up to
(excluding)
1.8.0-amazon-corretto-1.8.0_372.b07-1.amzn2023
运行在以下环境
系统 amazon_AMI java-1.8.0-openjdk * Up to
(excluding)
1.8.0-openjdk-javadoc-zip-1.8.0.382.b05-1.78.amzn1
运行在以下环境
系统 anolis_os_7 java-11-openjdk-demo-debug * Up to
(excluding)
1.8.0.372
运行在以下环境
系统 anolis_os_8 java-1.8.0-openjdk-accessibility * Up to
(excluding)
17.0.7.0.7-1
运行在以下环境
系统 centos_7 java-11-openjdk-demo * Up to
(excluding)
1.8.0.372.b07-1.el7_9
运行在以下环境
系统 centos_8 java-17-openjdk * Up to
(excluding)
1.8.0.372.b07-1.el8_7
运行在以下环境
系统 debian_10 openjdk-11 * Up to
(excluding)
11.0.20+8-1~deb10u1
运行在以下环境
系统 debian_11 openjdk-11 * Up to
(excluding)
11.0.20+8-1~deb11u1
运行在以下环境
系统 debian_12 openjdk-17 * Up to
(excluding)
17.0.7+7-1~deb12u1
运行在以下环境
系统 debian_sid openjdk-11 * Up to
(excluding)
11.0.19+7-1
运行在以下环境
系统 kylinos_aarch64_V10 tzdata * Up to
(excluding)
11.0.19.0.7-1.el7_9
运行在以下环境
系统 kylinos_x86_64_V10 tzdata * Up to
(excluding)
11.0.19.0.7-1.el7_9
运行在以下环境
系统 opensuse_Leap_15.4 java-17-openjdk-src * Up to
(excluding)
1.8.0.372-150000.3.79.1
运行在以下环境
系统 opensuse_Leap_15.5 java-1_8_0-ibm-plugin * Up to
(excluding)
1.8.0.372-150000.3.79.1
运行在以下环境
系统 oracle_7 oraclelinux-release * Up to
(excluding)
1.8.0.372.b07-1.el7_9
运行在以下环境
系统 oracle_8 oraclelinux-release * Up to
(excluding)
17.0.7.0.7-1.el8_7
运行在以下环境
系统 oracle_9 oraclelinux-release * Up to
(excluding)
11.0.19.0.7-1.0.1.el9_1
运行在以下环境
系统 redhat_7 java * Up to
(excluding)
1.8.0-openjdk-devel-1.8.0.372.b07-1.el7_9
运行在以下环境
系统 redhat_8 java-17-openjdk * Up to
(excluding)
1.8.0.372.b07-1.el8_7
运行在以下环境
系统 redhat_9 java * Up to
(excluding)
17-openjdk-headless-debuginfo-17.0.7.0.7-1.el9_1
运行在以下环境
系统 suse_12_SP5 java-1_8_0-ibm-alsa * Up to
(excluding)
1.8.0.372-27.87.1
运行在以下环境
系统 ubuntu_18.04 openjdk-17 * Up to
(excluding)
8u372-ga~us1-0ubuntu1~18.04
运行在以下环境
系统 ubuntu_20.04 openjdk-17 * Up to
(excluding)
8u372-ga~us1-0ubuntu1~20.04
运行在以下环境
系统 ubuntu_22.04 openjdk-17 * Up to
(excluding)
8u372-ga~us1-0ubuntu1~22.04
运行在以下环境
系统 ubuntu_22.10 openjdk-lts * Up to
(excluding)
8u372-ga~us1-0ubuntu1~22.10
运行在以下环境
系统 unionos_a java-11-openjdk * Up to
(excluding)
java-1.8.0-openjdk-1.8.0.372.b07-0.up2.uelc20.01
运行在以下环境
系统 unionos_e openjdk-latest * Up to
(excluding)
java-latest-openjdk-20.0.2.9-2.rolling.up1.uel20
阿里云评分
5.7
  • 攻击路径
    本地
  • 攻击复杂度
    困难
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况