中危 Requests 信息泄露漏洞(CVE-2023-32681)

CVE编号

CVE-2023-32681

利用情况

暂无

补丁情况

官方补丁

披露时间

2023-05-22
漏洞描述
自 Requests v2.3.0 以来,Requests 一直容易受到潜在泄漏的影响 Proxy-Authorization标头到目标服务器,特别是在重定向到 HTTPS 来源期间。 这是一个产品如何 rebuild_proxies用于重新计算和重新附加 Proxy-Authorization标头重定向时请求的 当在 URL 用户信息组件中提供凭据时才观察到此行为会 。 请注意,仅影响代理请求(例如 https://username:password@proxy:8080).
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 python requests * From
(including)
2.3.0
Up to
(excluding)
2.31.0
运行在以下环境
系统 alibaba_cloud_linux_3 python-requests * Up to
(excluding)
2.20.0-2.2.al8
运行在以下环境
系统 alma_linux_8 python3-requests * Up to
(excluding)
2.20.0-3.el8_8
运行在以下环境
系统 alma_linux_9 python3-requests * Up to
(excluding)
2.25.1-7.el9_2
运行在以下环境
系统 amazon_2 python-requests * Up to
(excluding)
2.6.0-10.amzn2.0.1
运行在以下环境
系统 amazon_2023 python-requests * Up to
(excluding)
2.25.1-1.amzn2023.0.3
运行在以下环境
系统 anolis_os_8 python-requests * Up to
(excluding)
2.20.0-2.2
运行在以下环境
系统 debian_10 requests * Up to
(excluding)
2.21.0-1+deb10u1
运行在以下环境
系统 fedoraproject fedora 37 -
运行在以下环境
系统 fedora_37 python-requests * Up to
(excluding)
2.28.1-3.fc37
运行在以下环境
系统 fedora_38 python-requests * Up to
(excluding)
2.28.2-2.fc38
运行在以下环境
系统 kylinos_aarch64_V10 python2-requests * Up to
(excluding)
2.24.0-2.ky10
运行在以下环境
系统 kylinos_aarch64_V10SP1 python2-requests * Up to
(excluding)
2.24.0-2.ky10
运行在以下环境
系统 kylinos_aarch64_V10SP2 python2-requests * Up to
(excluding)
2.24.0-2.ky10
运行在以下环境
系统 kylinos_aarch64_V10SP3 python2-requests * Up to
(excluding)
2.24.0-2.ky10
运行在以下环境
系统 kylinos_aarch64_V10SP32309b python2-requests * Up to
(excluding)
2.24.0-2.ky10
运行在以下环境
系统 kylinos_loongarch64_V10SP1 python2-requests * Up to
(excluding)
2.24.0-2.a.ky10
运行在以下环境
系统 kylinos_loongarch64_V10SP3 python2-requests * Up to
(excluding)
2.24.0-2.a.ky10
运行在以下环境
系统 kylinos_x86_64_V10 python2-requests * Up to
(excluding)
2.24.0-2.ky10
运行在以下环境
系统 kylinos_x86_64_V10SP1 python2-requests * Up to
(excluding)
2.24.0-2.ky10
运行在以下环境
系统 kylinos_x86_64_V10SP2 python2-requests * Up to
(excluding)
2.24.0-2.ky10
运行在以下环境
系统 kylinos_x86_64_V10SP3 python2-requests * Up to
(excluding)
2.24.0-2.ky10
运行在以下环境
系统 opensuse_5.3 python3-requests * Up to
(excluding)
2.24.0-150300.3.3.1
运行在以下环境
系统 opensuse_Leap_15.4 python3-requests * Up to
(excluding)
2.24.0-150300.3.3.1
运行在以下环境
系统 opensuse_Leap_15.5 python3-requests * Up to
(excluding)
2.24.0-150300.3.3.1
运行在以下环境
系统 oracle_8 python3-requests * Up to
(excluding)
2.20.0-3.el8_8
运行在以下环境
系统 oracle_9 python3-requests * Up to
(excluding)
2.25.1-7.el9_2
运行在以下环境
系统 redhat_8 python3-requests * Up to
(excluding)
2.20.0-3.el8_8
运行在以下环境
系统 redhat_9 python3-requests * Up to
(excluding)
2.25.1-7.el9_2
运行在以下环境
系统 rocky_linux_8 libdb-cxx * Up to
(excluding)
5.3.28-42.el8_4
运行在以下环境
系统 ubuntu_20.04 requests * Up to
(excluding)
2.22.0-2ubuntu1.1
运行在以下环境
系统 ubuntu_22.10 requests * Up to
(excluding)
2.27.1+dfsg-1ubuntu2.1
阿里云评分
5.7
  • 攻击路径
    本地
  • 攻击复杂度
    困难
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-200 信息暴露
NVD-CWE-noinfo
阿里云安全产品覆盖情况