中危 php缓冲区溢出漏洞(CVE-2023-3824)

CVE编号

CVE-2023-3824

利用情况

暂无

补丁情况

官方补丁

披露时间

2023-07-21
漏洞描述
在PHP版本8.0.*在8.0.30之前,8.1.*在8.1.22之前和8.2.*在8.2.8之前,在加载Phar文件时,在读取PHAR目录条目时,不足的长度检查可能会导致堆栈缓冲区溢出,可能导致内存损坏或RCE。
解决建议
"将组件 php 升级至 8.2.8 及以上版本"
"将组件 php 升级至 8.1.22 及以上版本"
"将组件 php 升级至 8.0.30 及以上版本"
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 php php * From
(including)
8.0.0
Up to
(excluding)
8.0.30
运行在以下环境
应用 php php * From
(including)
8.1.0
Up to
(excluding)
8.1.22
运行在以下环境
应用 php php * From
(including)
8.2.0
Up to
(excluding)
8.2.8
运行在以下环境
系统 alma_linux_9 php * Up to
(excluding)
8.0.30-1.el9_2
运行在以下环境
系统 alpine_3.16 php8 * Up to
(excluding)
8.1.22-r0
运行在以下环境
系统 alpine_3.17 php81 * Up to
(excluding)
8.1.22-r0
运行在以下环境
系统 amazon_2 php * Up to
(excluding)
8.2.9-1.amzn2
运行在以下环境
系统 amazon_2023 php8.1 * Up to
(excluding)
8.1.22-1.amzn2023.0.1
运行在以下环境
系统 anolis_os_23 php * Up to
(excluding)
8.2.10-1
运行在以下环境
系统 debian_10 php7.3 * Up to
(excluding)
7.3.31-1~deb10u5
运行在以下环境
系统 fedora_37 php * Up to
(excluding)
8.1.22-1.fc37
运行在以下环境
系统 fedora_38 php * Up to
(excluding)
8.2.9-1.fc38
运行在以下环境
系统 kylinos_aarch64_V10 php * Up to
(excluding)
7.2.34-3.ky10
运行在以下环境
系统 kylinos_aarch64_V10HPC php * Up to
(excluding)
8.0.30-1.ky10h
运行在以下环境
系统 kylinos_aarch64_V10SP1 php * Up to
(excluding)
7.2.34-3.p01.ky10
运行在以下环境
系统 kylinos_aarch64_V10SP2 php * Up to
(excluding)
7.2.34-3.ky10
运行在以下环境
系统 kylinos_aarch64_V10SP3 php * Up to
(excluding)
7.2.34-3.ky10
运行在以下环境
系统 kylinos_loongarch64_V10SP1 php * Up to
(excluding)
7.2.34-3.p01.a.ky10
运行在以下环境
系统 kylinos_loongarch64_V10SP3 php * Up to
(excluding)
7.2.34-3.p02.a.ky10
运行在以下环境
系统 kylinos_x86_64_V10 php * Up to
(excluding)
7.2.34-3.ky10
运行在以下环境
系统 kylinos_x86_64_V10HPC php * Up to
(excluding)
8.0.30-1.ky10h
运行在以下环境
系统 kylinos_x86_64_V10SP1 php * Up to
(excluding)
7.2.34-3.p01.ky10
运行在以下环境
系统 kylinos_x86_64_V10SP2 php * Up to
(excluding)
7.2.34-3.ky10
运行在以下环境
系统 kylinos_x86_64_V10SP3 php * Up to
(excluding)
7.2.34-3.ky10
运行在以下环境
系统 opensuse_Leap_15.4 php8 * Up to
(excluding)
8.0.30-150400.4.37.1
运行在以下环境
系统 opensuse_Leap_15.5 php8 * Up to
(excluding)
8.0.30-150400.4.37.1
运行在以下环境
系统 oracle_9 php * Up to
(excluding)
8.0.30-1.el9_2
运行在以下环境
系统 redhat_9 php * Up to
(excluding)
8.0.30-1.el9_2
运行在以下环境
系统 rocky_linux_9 php * Up to
(excluding)
8.0.30-1.el9_2
运行在以下环境
系统 ubuntu_22.04 php8.1 * Up to
(excluding)
8.1.2-1ubuntu2.14
阿里云评分
6.7
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况