中危 Google Golang 安全漏洞(CVE-2023-39319)

CVE编号

CVE-2023-39319

利用情况

暂无

补丁情况

官方补丁

披露时间

2023-09-09
漏洞描述
The html/template package does not apply the proper rules for handling occurrences of "<script", "<!--", and "</script" within JS literals in <script> contexts. This may cause the template parser to improperly consider script contexts to be terminated early, causing actions to be improperly escaped. This could be leveraged to perform an XSS attack.
解决建议
"将组件 go 升级至 1.21.1 及以上版本"
"将组件 go 升级至 1.20.8 及以上版本"
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 golang go * Up to
(excluding)
1.20.8
运行在以下环境
应用 golang go * From
(including)
1.21.0
Up to
(excluding)
1.21.1
运行在以下环境
系统 alma_linux_9 skopeo * Up to
(excluding)
1.13.3-3.el9_3
运行在以下环境
系统 alpine_3.18 go * Up to
(excluding)
1.20.8-r0
运行在以下环境
系统 alpine_3.19 go * Up to
(excluding)
1.21.1-r0
运行在以下环境
系统 amazon_2 golang * Up to
(excluding)
1.20.10-1.amzn2.0.1
运行在以下环境
系统 amazon_2023 golang * Up to
(excluding)
1.20.8-1.amzn2023.0.1
运行在以下环境
系统 amazon_AMI golang * Up to
(excluding)
1.20.8-1.47.amzn1
运行在以下环境
系统 anolis_os_23 golang * Up to
(excluding)
1.20.9-1
运行在以下环境
系统 fedora_EPEL_7 golang * Up to
(excluding)
1.19.13-1.el7
运行在以下环境
系统 kylinos_aarch64_V10 golang * Up to
(excluding)
1.15.7-36.ky10
运行在以下环境
系统 kylinos_aarch64_V10SP1 golang * Up to
(excluding)
1.15.7-36.ky10
运行在以下环境
系统 kylinos_aarch64_V10SP2 golang * Up to
(excluding)
1.15.7-36.ky10
运行在以下环境
系统 kylinos_aarch64_V10SP3 golang * Up to
(excluding)
1.15.7-36.ky10
运行在以下环境
系统 kylinos_aarch64_V10SP32309b golang * Up to
(excluding)
1.15.7-36.ky10
运行在以下环境
系统 kylinos_loongarch64_V10SP3 golang * Up to
(excluding)
1.15.7-36.p01.a.ky10
运行在以下环境
系统 kylinos_x86_64_V10 golang * Up to
(excluding)
1.15.7-36.ky10
运行在以下环境
系统 kylinos_x86_64_V10SP1 golang * Up to
(excluding)
1.15.7-36.ky10
运行在以下环境
系统 kylinos_x86_64_V10SP2 golang * Up to
(excluding)
1.15.7-36.ky10
运行在以下环境
系统 kylinos_x86_64_V10SP3 golang * Up to
(excluding)
1.15.7-36.ky10
运行在以下环境
系统 opensuse_Leap_15.4 go1.21 * Up to
(excluding)
1.21.1-150000.1.6.1
运行在以下环境
系统 opensuse_Leap_15.5 go1.21 * Up to
(excluding)
1.21.1-150000.1.6.1
运行在以下环境
系统 oracle_9 skopeo * Up to
(excluding)
1.13.3-3.el9_3
运行在以下环境
系统 redhat_9 skopeo * Up to
(excluding)
1.13.3-3.el9_3
运行在以下环境
系统 ubuntu_20.04 golang-1.20 * Up to
(excluding)
1.20.3-1ubuntu0.1~20.04.1
运行在以下环境
系统 ubuntu_22.04 golang-1.20 * Up to
(excluding)
1.20.3-1ubuntu0.1~22.04.1
阿里云评分
5.7
  • 攻击路径
    本地
  • 攻击复杂度
    困难
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况