中危 Tungstenite 允许远程攻击者造成拒绝服务 (CVE-2023-43669)

CVE编号

CVE-2023-43669

利用情况

暂无

补丁情况

官方补丁

披露时间

2023-09-21
漏洞描述
The Tungstenite crate through 0.20.0 for Rust allows remote attackers to cause a denial of service (minutes of CPU consumption) via an excessive length of an HTTP header in a client handshake. The length affects both how many times a parse is attempted (e.g., thousands of times) and the average amount of data for each parse attempt (e.g., millions of bytes).
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 snapview tungstenite * Up to
(including)
0.20.0
运行在以下环境
系统 amazon_2 firefox * Up to
(excluding)
115.4.0-1.amzn2.0.1
运行在以下环境
系统 fedora_37 rust-axum * Up to
(excluding)
0.6.20-1.fc37
运行在以下环境
系统 fedora_38 rust-axum * Up to
(excluding)
0.6.20-1.fc38
运行在以下环境
系统 fedora_39 rust-axum * Up to
(excluding)
0.6.20-1.fc39
运行在以下环境
系统 fedora_40 rust-axum * Up to
(excluding)
0.6.20-1.fc40
阿里云评分
6.2
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况