中危 firefox-esr 安全漏洞 (CVE-2023-4576)

CVE编号

CVE-2023-4576

利用情况

暂无

补丁情况

官方补丁

披露时间

2023-08-29
漏洞描述
On Windows, an integer overflow could occur in `RecordedSourceSurfaceCreation` which resulted in a heap buffer overflow potentially leaking sensitive data that could have led to a sandbox escape. *This bug only affects Firefox on Windows. Other operating systems are unaffected.* This vulnerability affects Firefox < 117, Firefox ESR < 102.15, Firefox ESR < 115.2, and Thunderbird < 115.2.


解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 mozilla firefox * Up to
(excluding)
117.0
运行在以下环境
应用 mozilla firefox_esr * Up to
(excluding)
102.15
运行在以下环境
应用 mozilla firefox_esr * From
(including)
115.0
Up to
(excluding)
115.2
运行在以下环境
应用 mozilla thunderbird * Up to
(excluding)
115.2
运行在以下环境
系统 alpine_3.18 firefox-esr * Up to
(excluding)
115.2.0-r0
运行在以下环境
系统 alpine_3.19 firefox-esr * Up to
(excluding)
115.2.0-r0
运行在以下环境
系统 debian_10 firefox-esr * Up to
(excluding)
115.7.0esr-1~deb10u1
运行在以下环境
系统 debian_11 firefox-esr * Up to
(excluding)
115.7.0esr-1~deb11u1
运行在以下环境
系统 debian_12 firefox-esr * Up to
(excluding)
115.7.0esr-1~deb12u1
运行在以下环境
系统 microsoft windows - -
运行在以下环境
系统 opensuse_Leap_15.4 MozillaFirefox * Up to
(excluding)
115.2.0-150200.152.102.1
运行在以下环境
系统 opensuse_Leap_15.5 MozillaFirefox * Up to
(excluding)
115.2.0-150200.152.102.1
运行在以下环境
系统 suse_12_SP5 MozillaFirefox * Up to
(excluding)
115.2.0-112.176.1
阿里云评分
6.4
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-190 整数溢出或超界折返
阿里云安全产品覆盖情况