中危 Google Chrome blink渲染引擎存在 UAF 漏洞(CVE-2023-5997)

CVE编号

CVE-2023-5997

利用情况

暂无

补丁情况

官方补丁

披露时间

2023-11-16
漏洞描述
Google Chrome 是 Google 公司开发的网页浏览器。blink 是一个Chromium用来解析和渲染的网页的引擎。
在 blink 渲染引擎中,处理网络请求时会通过DidFetchDataLoadedString创建URLSearchParams::Create对象,但是由于返回堆上对象,使用的内存有可能会被垃圾回收(garbage collect,GC),引起内存释放后使用(Use After Free)的问题。
漏洞修复通过修改对象为Persistent类型的变量并将其存储在栈上,从而避免了 UAF 的问题。
解决建议
"将组件 chromium 升级至 119.0.6045.159-1 及以上版本"
"将组件 chromium 升级至 119.0.6045.159 及以上版本"
"升级至 119.0.6045.159 及以上版本"
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 google chrome * Up to
(excluding)
119.0.6045.159
运行在以下环境
系统 alpine_3.18 qt5-qtwebengine * Up to
(excluding)
5.15.13-r12
运行在以下环境
系统 alpine_3.19 qt5-qtwebengine * Up to
(excluding)
5.15.16-r0
运行在以下环境
系统 debian_11 chromium * Up to
(excluding)
119.0.6045.159-1~deb11u1
运行在以下环境
系统 debian_12 chromium * Up to
(excluding)
119.0.6045.159-1~deb12u1
运行在以下环境
系统 fedora_37 chromium * Up to
(excluding)
119.0.6045.159-2.fc37
运行在以下环境
系统 fedora_38 chromium * Up to
(excluding)
119.0.6045.159-2.fc38
运行在以下环境
系统 fedora_39 chromium * Up to
(excluding)
119.0.6045.159-2.fc39
运行在以下环境
系统 fedora_EPEL_7 chromium * Up to
(excluding)
119.0.6045.159-1.el7
运行在以下环境
系统 fedora_EPEL_8 chromium * Up to
(excluding)
119.0.6045.159-1.el8
运行在以下环境
系统 fedora_EPEL_9 chromium * Up to
(excluding)
119.0.6045.159-2.el9
运行在以下环境
系统 opensuse_Leap_15.4 opera * Up to
(excluding)
105.0.4970.21-lp154.2.62.1
运行在以下环境
系统 opensuse_Leap_15.5 opera * Up to
(excluding)
105.0.4970.21-lp155.3.21.1
阿里云评分
6.6
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-416 释放后使用
阿里云安全产品覆盖情况