python-django 安全漏洞 (CVE-2024-27351)

CVE编号

CVE-2024-27351

利用情况

暂无

补丁情况

N/A

披露时间

2024-03-16
漏洞描述
In Django 3.2 before 3.2.25, 4.2 before 4.2.11, and 5.0 before 5.0.3, the django.utils.text.Truncator.words() method (with html=True) and the truncatewords_html template filter are subject to a potential regular expression denial-of-service attack via a crafted string. NOTE: this issue exists because of an incomplete fix for CVE-2019-14232 and CVE-2023-43665.
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 opensuse_Leap_15.5 python3-Django * Up to
(excluding)
2.0.7-150000.1.17.1
运行在以下环境
系统 ubuntu_20.04 python-django * Up to
(excluding)
2.2.12-1ubuntu0.22
运行在以下环境
系统 ubuntu_22.04 python-django * Up to
(excluding)
3.2.12-2ubuntu1.11
CVSS3评分
N/A
  • 攻击路径
    N/A
  • 攻击复杂度
    N/A
  • 权限要求
    N/A
  • 影响范围
    N/A
  • 用户交互
    N/A
  • 可用性
    N/A
  • 保密性
    N/A
  • 完整性
    N/A
CWE-ID 漏洞类型
阿里云安全产品覆盖情况